Jump to content
The Uniform Server Community

Recommended Posts

Hi,

sorry to ask as I'm sure this question has been asked allot and I'm sure it has been answered allot, however i did a search on Google and this site and haven't found an answer or may not be looking in the right place i been using uniserver since the mona days and i was never really bothered by the question i was just using the server as private to work on my sites and stuff but about 6 months backish i upgraded to coral and kept it private and just recently i wanted to probably use it as a live site for my main site so i secured it down and asked others if they can see my site via URL mysite.com everyone said they could see it accept me i can only view it via localhost how can i view via URL as well? some said it has to do with my router and ports.. the ports are open or no one can see the page correct? some said to allow the machine to be in DMZ not an option again everyone can see it via URL so it wouldn't be a firewall issue and no need to go that drastic to put the machine out in the open so to speak. is there something i could do to the uniserver config or is there a way that will allow me to see it as others? I'm running uniserver 8.9.2

 

Again sorry if i posted in wrong spot

Thanks

Rob

Share this post


Link to post
Share on other sites

This is a typical conundrum, and it has no connection with The Uniform Server, but is a function of your router and local network. Any other WAMP would have the same problem.

The router acts as a fence, and all your own access comes from within. It doesn't go through the NAT translation, which is normally applied to all external traffic.

 

I have tested my sites by setting up an external connection, using a mobile broadband connection, or by accessing it from work using a remote connection (if that's possible in your case). These connections go through the router's WAN connection and thus through the NAT translation and routing to your WAMP.

 

Regards,

BobS

Share this post


Link to post
Share on other sites

This is a typical conundrum, and it has no connection with The Uniform Server, but is a function of your router and local network. Any other WAMP would have the same problem.

The router acts as a fence, and all your own access comes from within. It doesn't go through the NAT translation, which is normally applied to all external traffic.

 

I have tested my sites by setting up an external connection, using a mobile broadband connection, or by accessing it from work using a remote connection (if that's possible in your case). These connections go through the router's WAN connection and thus through the NAT translation and routing to your WAMP.

 

Regards,

BobS

Thanks BobS for the reply,,

so what you saying unless i set up another outside connection there is really no way to allow me to view other than by localhost?someone mentioned to me last night also that if i add the URL to my host file it should work as well?

Share this post


Link to post
Share on other sites

Actually I have a separate server, but to help you. Try this. Go to any site check site.http://www.downforeveryoneorjustme.com/ http://www.downforeveryoneorjustme.com/

and for a list of places you can use go here http://www.google.com/search?q=site+checker&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

 

I use these sites rather than opening the router as that imposes a additional security risk. I have been attacked and compromised but not because of Uniform Server just a visit to a hacked web site infected a box 7 years ago, I have severely changed practices since then. I highly recommend NOT opening any thing you do not need.

Share this post


Link to post
Share on other sites

thanx for the tip B)

i did fix it using the host file and doing the following

go to and open

X:\Windows\System32\drivers\etc\host

and added

127.0.0.1       mysite.com

will this cause conflict or leave me open for hacks?

Share this post


Link to post
Share on other sites

you should be fine with the hosts file. I use the Hosts file to block spammers and others that cause issues, I prefer it over putting them in the confg file or the other one. as it is system wide not limited to just a web server.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...