Jump to content
The Uniform Server Community
xac

MySQL access from remote desktop

Recommended Posts

Support Forum,

 

I just started using Uniform Server on a Windows XP Pro system to be used for software testing. I defined a web site and Apache is working great.

 

The problem that I'm having is that I cannot connect the the MySQL database from any other desktop on the network. I have written a very simple application that just tries to connect the the MySQL server based on the location, databaseName, user and password. When I run it on the same desktop that Uniform Server is installed it works great, however when I run it from a different Windows 7 desktop on the network the connection fails with the following error message. "Can't connect to MySQL server on '192.168.1.117' (0)" Something must be blocking network access to MySQL.

 

I've done the following to open the MySQL Server for network access with no luck.

> Disabled the windows firewalls on both systems

> Set the WWW configuration from Local and Intranet access

> Set the my.ini configuration to contain bind-address = 0.0.0.0 so it will allow connection on all ports

> Made sure that skip-networking was not part of the my.ini configuration file

> Run $ netstat -abn -p TCP to show that port 3306 is being monitored by mysql

> Defined a user named 'sha' with full privileges access to the specific database with HOST set to %. The phpmyadmin definition:

USER HOST PASSWORD GLOBAL PRIVILEGES

sha % Yes ALL PRIVILEGES

sha 127.0.0.1 Yes ALL PRIVILEGES

sha 192.168.1.73 Yes ALL PRIVILEGES

 

I must be missing something that needs to be done to allow remote access to the MySQL server.

 

Any help would be appreciated.

Thanks

Share this post


Link to post
Share on other sites

Hello

 

I am struggling to solve the same problem. I can access the database on the same computer using localhost or 127.0.0.1 but if I put the computer IP 192.168.1.10 it does not work anymore.

I have:

enabled intranet access,

user privileges to % (all hosts)

bind-address = 0.0.0.0 in etc/my.ini file

disabled windows firewall

 

Help please!! :(

Share this post


Link to post
Share on other sites

Solution:

 

This topic is old but follow my tip for reference. In file "my.ini" comment out the following line:

 

From:

 

bind-address=127.0.0.1

 

To:

 

#bind-address=127.0.0.1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...