Jump to content
The Uniform Server Community
Sign in to follow this  
JQX

Apache security question

Recommended Posts

Hi,

 

I just installed Uniform Server to Windows Server. This server hosts a web page that is available from internet.

 

If I open web browser and type "http://server_ip" it opens the "index of" page and shows one folder (web page folder that this server is hosting) and favicon file. I want to restrict access to this root directory and want to allow access only to this http://server_ip/hosted_web_page. How I can do this?

Share this post


Link to post
Share on other sites

I figured it out.

 

I added "Options -Indexes" to httpd.conf -file in www -folder and now it says "You don't have permission to access / on this server".

Share this post


Link to post
Share on other sites

Restricting access to root folder www is configurable from the server configuration menu. First undo any changes you have made httpd.conf these are not required.

 

Read the manual page; Root folder www – Access (general_access_www.html) it provides details for setting root folder access and restricting access using a name/password.

 

View manual page:

From folder UniServer run help.exe – This opens manual in default browser

Left menu click item General – Opens general page

Left menu click item Root folder www Access

All the best

Ric

Share this post


Link to post
Share on other sites

Restricting access to root folder www is configurable from the server configuration menu. First undo any changes you have made httpd.conf these are not required.

 

Read the manual page; Root folder www – Access (general_access_www.html) it provides details for setting root folder access and restricting access using a name/password.

 

View manual page:

From folder UniServer run help.exe – This opens manual in default browser

Left menu click item General – Opens general page

Left menu click item Root folder www Access

All the best

Ric

 

Hi,

 

I tried that already but after that I can no longer access the web page under the root folder anymore.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...