Jump to content
The Uniform Server Community
Sign in to follow this  
John Smith

SSL connection reset

Recommended Posts

Hi all!

 

I'm having a problem with the latest Uniform Server versions when using SSL. I experience very frequent connection resets. And I never managed to make a successful connection from localhost via SSL. From other machines yes, but only sometimes. Regular HTTP works fine though.

 

I'm currently running Coral 8.0.0 (OpenSSL 1.0.0e) and everything works fine. But I'm trying to update since version 8.5.2. I guess it has something to do with OpenSSL which is at version 1.0.1 now and hasn't been upgraded during the last 4 releases.

 

Any thoughts on that? Does anyone else have the same problem perhaps? I didn't change much of the default configuration. Basically only the ports. I'm using 60001 for SSL. I trust that's not a problem?

 

Thanks for any help in advance.

Share this post


Link to post
Share on other sites

A solution to your immediate problem:

Edit file: UniServer\usr\local\apache2\conf\extra\httpd-ssl.conf

 

Add https to the end of the Listen port directive

 

For example:

Listen 8443 https

 

Note: If you change the port from the menus https will be removed hence you need to repeat the above.

 

Note: OpenSSL will be updated in the next version.

All the best

Ric :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...