Jump to content
The Uniform Server Community
Sign in to follow this  
Cringer

xdebug extension

Recommended Posts

I have downloaded XDebug (php_xdebug-2.2.0-5.4-vc9-nts-x86_64.dll) and put the .dll in C:\UniServer\usr\local\php\extensions as well as added the following to my php.ini (both development and production).

 

[xdebug]

zend_extension=C:/UniServer/usr/local/php/extensions/php_xdebug-2.2.0-5.4-vc9-nts-x86_64.dll

xdebug.remote_autostart=on

xdebug.remote_enable=on

xdebug.remote_host=127.0.0.1

xdebug.remote_port=9000

xdebug.remote_handler=dbgp

xdebug.remote_mode=req

xdebug.idekey=default

 

Doing so added it as a checkable option under Server Configuration -> PHP -> PHP Extensions Enable/Disable. I check the box to enable it but once I close this screen it toggles back off. When I check or uncheck other extensions and close the screen they stay in the expected state. When I check phoinfo, it shows the correct configuration file is loaded, but does not list xdebug. I assume this is because the extension will not stay toggled. Does anyone know why this keeps untoggling?

Share this post


Link to post
Share on other sites

The php module "XDebug (php_xdebug-2.2.0-5.4-vc9-nts-x86_64.dll)" is incompatible and will not work. B)

 

The module switching “Extensions Enable/Disable” issue is a bug. :blink:

This has been corrected in Uniform Server 8.5.5-Coral. :)

 

Note: Uniform Server 8.5.5-Coral also includes compatible XDebug module. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...