Jump to content
The Uniform Server Community
Sign in to follow this  
Guest bsenftner

is it possible to run php 5.3 in Coral 8.4.0?

Recommended Posts

Guest bsenftner

Topic says all. I want to use the latest coral version, but portions of my FOSS framework only function with php 5.3...

Share this post


Link to post
Share on other sites

You can extractg the PHP subdirectory from an earlier Coral version, like Coral_8.1.2. This has PHP 5.3.10, which was a security update.

 

The MAIN problem will be matching all the paths in the php.ini files with what's in uni_con\config_tracker.ini of the 8.4.0 version.

 

Unpack the two versions of The Uniform Server into two different directories. I suggest you use C:\Coral_8_4_0 and C:\Coral_8_1_2 as the names.

Copy the usr\local\php directory of the older version to the newer one. Then edit each PHP*.ini file and change all "C:/Coral_8_1_2/UniServer" references to "C:/Coral_8_4_0/UniServer".

 

Keep this updated directory as a template -- DON'T run it, as this will trigger the automatic path change mechanism. I suggest you change the containing directory to "C:\Coral_8_4_x" to differentiate it. you can 7zip it so it stays as a unit. Then you can create a COPY of it and run that instead.

 

I believe that's all that's necessary to drop back. Be sure to update this thread with your results. :)

 

Regards,

BobS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...