Jump to content
The Uniform Server Community
traxxus

Cron services not installable

Recommended Posts

Hi UniFormServer devs

 

I using Coral 8.0 final in Windows Server 2008 x32.

I can't install thr Cron service.

 

When i press "Install and Run Service", nothing is going on.

After a few secons the Button apperas again in violet.

 

"Run Cron as program" works.

Share this post


Link to post
Share on other sites

I am also experiencing this issue. I have tried both 8.5 and 8.4 to no success. Further trying to install as service manually and run as program manually both seem to fail. It only seems to run from the new unitray replacement.

Share this post


Link to post
Share on other sites

I can confirm this issue on v8.5.5.

 

It fails to run the service. I've tried to delete the service, install it again, but it's the same. I've managed to track the problem down:

 

ERROR: Exception 7 trapped in source file 'D:\Home\Author\srvstart.v110\dll\CmdRunner.cpp' line 296

ERROR: Class 'CmdRunner' method 'CmdRunner'

An internal error has occurred.

I've run the service manually from cmd, using the cmd line that was specified in the service, i.e.

C:\UniServer\uni_con\cron_service\srvstart.exe svc coral_cron -c C:\UniServer\uni_con\cron_service\srvstart.ini

And I've captured the output of srvstart.exe, by appending "> srvstart.log". Like this

C:\UniServer\uni_con\cron_service\srvstart.exe svc coral_cron -c C:\UniServer\uni_con\cron_service\srvstart.ini > C:\UniServer\uni_con\cron_service\srvstart.log

 

Hopefully, it will be fixed in new version.

 

Edit: There is some serious problem. I just launched srvstart.exe, without any cmd line, and here is what it outputs:

SRVSTART: 2012/07/01 08:28:48 ERROR severity=0 thread=2812 source=D:\Home\Author\srvstart.v110\exe\exe.cpp line=229 text=Invalid syntax

 

 

SRVSTART version 1.10

Copyright © 1998 - 2000 Nick Rozanski (Nick@Rozanski.com)

 

Start a program with a given environment, and optionally as a NT service

or install / remove an NT service which uses SRVSTART

 

Syntax for command mode:

srvstart cmd window_title [options] command [program_parameters...]

 

Syntax for service mode:

srvstart [ svc ] service_name [options] command [program_parameters...]

 

Syntax for any mode (try service, then command):

srvstart any service_name [options] command [program_parameters...]

 

Syntax for install mode:

srvstart install|install_desktop service_name -c controlfile

 

Syntax for remove mode:

srvstart remove service_name

 

service_name is short (internal) name of NT service

 

options:

 

-e var=value assign value to environment variable var

-p path assign value of %PATH%

-l libdir assign value of %LIB%

-s sybase assign value of %SYBASE% variable

-q sybase assign default %PATH% based on this value of %SYBASE%

 

-x priority run at given execution priority (normal/high/real/idle)

-w start in new window (command mode only)

-m start in minimised new window (command mode only)

-y sec delay sec seconds before reporting 'started' (service mode only)

-t sec program status check interval (service mode only)

 

-d level debug level (0/1/2, 2 highest)

-o target send debug output to target (filename or - for stdout or LOG for NT Event Log)

-c ctrlfile get srvstart options from file ctrlfile

-h displaSRVSTART: 2012/07/01 08:28:48 ERROR severity=0 thread=2812 source=D:\Home\Author\srvstart.v110\exe\exe.cpp line=449 text=SRVSTART is terminating with a FAILURE status

y this help message

 

Substitute parameters in command using {prompt} or {prompt:default}

Substitute environment vars in command using %variable%

Refer to exe.cpp for details.

 

Distributed under the terms of the GNU General Public License as published by the Free Software Foundation

 

Running on Win7 Pro x64. Btw, Is that really a open-source tool? Does anyone know where I can find the source code? I would like to fix this issue :]

Share this post


Link to post
Share on other sites

The solution is sooo simple:

 

- open ".....\UniServer\uni_con\cron_service\srvstart.ini" with an editor

- replace the section header "[uS_CronS1]" by "[coral_cron]"

- save and close the file

 

... and you are done ...
___

 

Remark: I'm a little bit surprised nobody since July 2012 found it worth to post the solution for that simple bug. Or did really nobody see it?

Share this post


Link to post
Share on other sites

 

The solution is sooo simple:

 

- open ".....\UniServer\uni_con\cron_service\srvstart.ini" with an editor

- replace the section header "[uS_CronS1]" by "[coral_cron]"

- save and close the file

 

... and you are done ...

___

 

Remark: I'm a little bit surprised nobody since July 2012 found it worth to post the solution for that simple bug. Or did really nobody see it?

 

Works like a charm

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...