Jump to content
The Uniform Server Community
Sign in to follow this  
tomharto

Double dot files names

Recommended Posts

I have a site using a few files with the filenames in ths format "_inc.somename.php" and for some reason when i try and use them on Uniserver the just show up as blank. Is this a known issue / is there a fix or work around for this?

Share this post


Link to post
Share on other sites

If your pages work on other servers and fail on Uniserver they probably use short open tags <? ?> use the long form <?php ?>

Share this post


Link to post
Share on other sites

If your pages work on other servers and fail on Uniserver they probably use short open tags <? ?> use the long form <?php ?>

 

They use the long ones

 

This is the opening part of my index page

 

<?php

session_start();

error_reporting (E_ALL ^ E_NOTICE);

 

$styleSheet = "stylee.css";

include ("include/config.php");

include ("include/function.php");

include ("include/function_homepage.php");

 

$hpInfo = "";

getHomepageInfo($hpInfo);

require_once ("_inc.header.php");

$userID = $_SESSION['userID'];

 

?>

 

if i go directly to _inc.header.php it shows blank too and that uses full <?php tags too

Share this post


Link to post
Share on other sites

Stop the servers.

From the tray menu switch php.ini to development

Restart server

 

Try this code:

Save both files to folder UniServer\www

File index.php

<?php
 //Main test file index.php
 echo "<h1>Test 1</h1>";
 require_once ("_inc.header.php");
?>

 

File _inc.header.php

<?php

  //Include file _inc.header.php
 echo "<h1>Hello World!</h1>";
?>

 

Start servers

Type following into browser address bar

http://localhost/index.php

 

What errors are reported?

Share this post


Link to post
Share on other sites

Stop the servers.

From the tray menu switch php.ini to development

Restart server

 

Try this code:

Save both files to folder UniServer\www

File index.php

<?php
 //Main test file index.php
 echo "<h1>Test 1</h1>";
 require_once ("_inc.header.php");
?>

 

File _inc.header.php

<?php

  //Include file _inc.header.php
 echo "<h1>Hello World!</h1>";
?>

 

Start servers

Type following into browser address bar

http://localhost/index.php

 

What errors are reported?

 

 

That works okay, must be a problem in my files coding then, i thought since it worked on my web server and not uniserver it was something to do with that. Ill check it all over and report back if i still have problems, thanks :)

Share this post


Link to post
Share on other sites

That works okay, must be a problem in my files coding then, i thought since it worked on my web server and not uniserver it was something to do with that. Ill check it all over and report back if i still have problems, thanks :)

 

It was a <? in my _inc.header.php. Was an include at the bottom of it what i missed, thanks for your help :(

Share this post


Link to post
Share on other sites

So Coral called it right to begin with :)

Coral: 1, bad php code: 0

 

Regards,

BobS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...