Jump to content
The Uniform Server Community
Sign in to follow this  
gratzo

how to enable EXIF

Recommended Posts

I've searched the forum and only could find one reference to EXIF data, and the Uniform Server. A topic started in February, but not ever closed that I can tell.

 

Currently running Windows 2000Pro, US v3.2a, and would like to capture the EXIF data - notice that this is not enabled in PHP. Is there a way to enable it? I realize that the UniformServer is kept at a minimum size with only the basics as the default install - hoping that there is a way to enable it without having to completely re-install US.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

What you need to do:

 

1. Go to www.php.net and download the package that is on your current Uniform Server. If you are using Uniform Server 3.2a, that would be PHP 5.0.4

 

2. After download, copy the extention php_exif.dll to the /usr/local/php/extensions/ folder.

 

3. Check to make sure that the php_mbstring.dll file is in that folder. The /usr/local/php/extensions/ folder. If it isn't, copy it there.

 

4. Edit the php.ini file in /usr/local/php/ folder. Uncomment the extension, php_exif.dll in the file. Make sure that the extension comes after the php_mbstring.dll extension. If the php_mbstring.dll extension is also commented, which it shouldn't, uncomment it.

 

Hope that works... good luck.

Share this post


Link to post
Share on other sites
What you need to do:

 

1. Go to www.php.net and download the package that is on your current Uniform Server. If you are using Uniform Server 3.2a, that would be PHP 5.0.4

 

2. After download, copy the extention php_exif.dll to the /usr/local/php/extensions/ folder.

 

3. Check to make sure that the php_mbstring.dll file is in that folder. The /usr/local/php/extensions/ folder. If it isn't, copy it there.

 

4. Edit the php.ini file in /usr/local/php/ folder. Uncomment the extension, php_exif.dll in the file. Make sure that the extension comes after the php_mbstring.dll extension. If the php_mbstring.dll extension is also commented, which it shouldn't, uncomment it.

 

Hope that works... good luck.

1564[/snapback]

 

Thanks! Something strange, however...I was probably using a photo that had been modified by photoshop, and "save-for-web", which I believe strips the exif data. I tried a couple of different photos, and the exif data shows up, without doing the above modification. (so now I'm stumped, thinking that I needed to enable EXIF...but it's reading it, so I didn't need to enable it...weird!)

 

Thanks anyway...will be posting another quick question regarding sendmail in a moment.

Share this post


Link to post
Share on other sites

 

 

4. Edit the php.ini file in /usr/local/php/ folder. Uncomment the extension, php_exif.dll in the file. Make sure that the extension comes after the php_mbstring.dll extension. If the php_mbstring.dll extension is also commented, which it shouldn't, uncomment it.

 

 

FYI, I just did this for US3.5 and the php.ini file move php_exif.dll first, so I had to move it AFTER the line for php_mbstring.dll. It seems like the default ini file should be fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...