Jump to content
The Uniform Server Community
Sign in to follow this  
jafo

Magento

Recommended Posts

I was able to install magento by using 127.0.0.1 and it works fine.

 

Here is the problem. I have a client who wants me to take an existing magneto installation and modify the css to look like an entirely different store. Imported the database and copied all of the files. configured the local.xml file to reflect the changes.

 

When I go to the home page I get the following errors.

 

 

SQLSTATE[HY000] [2002] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

 

 

Trace:

#0 C:\UniServer\www\phamba\lib\Zend\Db\Adapter\Pdo\Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()

#1 C:\UniServer\www\phamba\lib\Varien\Db\Adapter\Pdo\Mysql.php(251): Zend_Db_Adapter_Pdo_Mysql->_connect()

#2 C:\UniServer\www\phamba\lib\Zend\Db\Adapter\Abstract.php(448): Varien_Db_Adapter_Pdo_Mysql->_connect()

#3 C:\UniServer\www\phamba\lib\Zend\Db\Adapter\Pdo\Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)

#4 C:\UniServer\www\phamba\lib\Varien\Db\Adapter\Pdo\Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)

#5 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Resource\Type\Db\Pdo\Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')

#6 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Resource.php(93): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))

#7 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Mysql4\Abstract.php(297): Mage_Core_Model_Resource->getConnection('core_read')

#8 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Mysql4\Abstract.php(312): Mage_Core_Model_Mysql4_Abstract->_getConnection('read')

#9 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Mysql4\Cache.php(41): Mage_Core_Model_Mysql4_Abstract->_getReadAdapter()

#10 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Cache.php(424): Mage_Core_Model_Mysql4_Cache->getAllOptions()

#11 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Cache.php(459): Mage_Core_Model_Cache->_initOptions()

#12 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\App.php(1100): Mage_Core_Model_Cache->canUse('config')

#13 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Config.php(404): Mage_Core_Model_App->useCache('config')

#14 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\Config.php(286): Mage_Core_Model_Config->_canUseCacheForInit()

#15 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\App.php(359): Mage_Core_Model_Config->loadModulesCache()

#16 C:\UniServer\www\phamba\app\code\core\Mage\Core\Model\App.php(295): Mage_Core_Model_App->_initModules()

#17 C:\UniServer\www\phamba\app\Mage.php(596): Mage_Core_Model_App->run(Array)

#18 C:\UniServer\www\phamba\index.php(78): Mage::run('', 'store')

#19 {main}

 

---------------------------------------------------------------------------------------------------------------------

 

the setting in the local.xml file that associates the path for mysql.sock is pointed at /tmp/mysql.sock

when I change it too say 127.0.0.1 then I get a bad host name Invalid host. I have tried numerous variations and all the other settings are correct including core_conf in magneto to reflect the virtual domain name.

 

Any ideas? Thanks!

 

Also, there is nothing in logs. I think it comes down to the way it tries to connect to the socket. Any idea?

Share this post


Link to post
Share on other sites

Just a stab in the dark, but do I see a reference to MySQL4 in the dump? Since US 5.x uses MySQL 5, could it be that the problem is you're using code meant for MySQL 4 instead of MySQL 5?

 

Regards,

BobS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...