Jump to content
The Uniform Server Community
Sign in to follow this  
Riful

Error 403: Forbidden Access

Recommended Posts

Hi, I have looked through the wiki and forums and have found no answer to my problem.

I have also tried numerous versions to no avail. At a fresh install, I get this error denying me access to anything. Also when I run server status, it returns "Not Running" however in my services I can see that the service is enabled and active. One other thing, I can connect to the MYSQL server, but I have noticed something strange, databases are showing up from another UniServer folder when that server isn't active at all. When I disable UniServer, that database is inaccessible again.

Share this post


Link to post
Share on other sites

First of all, what version of UniServer is giving you this problem? Second, you say there is another version on your system? What are the path names for each instance?

 

As a general comment, if the .htaccess file in www is not set right, you will get a 403 error. A solution may be to change the "Allow from 127.0.0.1" to "Allow from 127.0.0.1 192.168", which will allow other systems on your LAN to access the server. It also will allow you to use the name of the machine, such as "http://mymach".

 

Bob

Share this post


Link to post
Share on other sites

I tried several 5.x versions, both exe and zip type installs into c:\UniServer and could not get apanel to come up. I got Forbidden 403 error on http://localhost/apanel but other test pages I put in were served up just fine. No other webservers running. This was a relatively plain XP SP2 installation. I tried the same vers 5.6.7 on a Win7 and another XP machine and they both run apanel just fine.

 

Checked ports 80 and 3306 available before starting, then started the server and saw 80 and 3306 active. Tried editing .htaccess as described to no avail. I needed a clue.

 

The breakthrough came when I added the line

 

Options +FollowSymLinks

 

to the bottom of .htaccess in home\admin\www. This tells Apache to follow symbolic links. ie. http://localhost/apanel actually points to C:\UniServer\home\admin\www which is NOT in the usual c:\UniSever\www directory.

 

This enabled apanel to run without the forbidden 403 message. Whew - it took an entire afternoon to fix this one.

Share this post


Link to post
Share on other sites

The breakthrough came when I added the line

 

Options +FollowSymLinks

 

to the bottom of .htaccess in home\admin\www. This tells Apache to follow symbolic links. ie. http://localhost/apanel actually points to C:\UniServer\home\admin\www which is NOT in the usual c:\UniSever\www directory.

 

This enabled apanel to run without the forbidden 403 message. Whew - it took an entire afternoon to fix this one.

THANK YOU for posting that -- it helped me too!

 

Now, after 3 days of failure, I can see the admin panel.

 

Next up: why do I get this: "#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)" when I access this: http://localhost/apanel/phpmyadmin/

 

Thanks and cheers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...