Jump to content
The Uniform Server Community

Recommended Posts

I have UniServer v. 5.6.7 and I am trying to install AWStats 1.0 with the instructions below. The install is not working. Am I using the right version of AWStats? This is confusing because I can find at least 3 different pages on the Wiki for this puglin with different instructions. What do I need to do to get this plugin to work?

 

Download file UniServer_AWStats_1.0.zip from Sourceforge

Save to any folder

Extract files, navigate to folder UniServer_AWStats_1.0

Copy the entire contents (read_me.txt and folder udrive) to the

installed Uniform Server's folder UniServer allow overwrite.

Share this post


Link to post
Share on other sites

I have just run this on 5.6.7 works fine

 

Instructions can be found in the read_me.txt file:

 

1] Run the servers once check they are working

 

2] Copy file V5.0_AWStats_1.0.exe to folder UniServer

Double click on file to run the self-extracting archive

 

3] Update Shebang:

Left mouse click on UniTray, mouse over "Advanced" and select

"Perl Shebang Update cgi-bin"

 

Note: Step three is required for first time installation. If you move servers to a different location shebang is automatically updated.

 

Note: I deleted double post.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Thank you for the reply to my question. I followed your instructions but I still cannot get the interface to appear on http://localhost/cgi-bin/awstats/aswstats.pl.

 

I have a question about the version of AWStats that you mention. Where did you obtain that version 5?

 

Thank you again.

CH

 

 

I have just run this on 5.6.7 works fine

 

Instructions can be found in the read_me.txt file:

 

1] Run the servers once check they are working

 

2] Copy file V5.0_AWStats_1.0.exe to folder UniServer

Double click on file to run the self-extracting archive

 

3] Update Shebang:

Left mouse click on UniTray, mouse over "Advanced" and select

"Perl Shebang Update cgi-bin"

 

Note: Step three is required for first time installation. If you move servers to a different location shebang is automatically updated.

 

Note: I deleted double post.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Version I used can be obtained from:

 

http://sourceforge.net/projects/miniserver....0_AWStats_1.0/

 

It installs a mini-version of Perl.

 

Just wondering can you get the simple “Hello World” page to display

 

http://localhost/cgi-bin/test.pl

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

I'm also having the same problem with AWStats using 5.6.13-Nano. I already had Perl 5.10 installed and the test.pl file in cgi-bin executes "Hello World". Since I already had Perl, I installed AWStats file UniServer_AWStats_1.0.zip and I also tried UniServer_AWStats_1.0.exe. Typing http://localhost/cgi-bin/awstats/awstats.pl into the browser address bar returns:

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

error log entries:

[Fri Apr 22 01:48:10 2011] [error] [client 127.0.0.1] Premature end of script headers: awstats.pl

[Fri Apr 22 01:48:10 2011] [error] [client 127.0.0.1] Encode object version 2.35 does not match bootstrap parameter 2.23 at C:/Utilities/UniServer/usr/lib/XSLoader.pm line 94.\r

[Fri Apr 22 01:48:10 2011] [error] [client 127.0.0.1] Compilation failed in require at C:/Utilities/UniServer/cgi-bin/awstats/awstats.pl line 19.\r

[Fri Apr 22 01:48:10 2011] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at C:/Utilities/UniServer/cgi-bin/awstats/awstats.pl line 19.\r

[Fri Apr 22 01:49:27 2011] [error] [client 127.0.0.1] script not found or unable to stat: C:/Utilities/UniServer/cgi-bin/awstats/test.pl

[Fri Apr 22 01:54:53 2011] [error] [client 127.0.0.1] Premature end of script headers: awstats.pl

[Fri Apr 22 01:54:53 2011] [error] [client 127.0.0.1] Encode object version 2.35 does not match bootstrap parameter 2.23 at C:/Utilities/UniServer/usr/lib/XSLoader.pm line 94.\r

[Fri Apr 22 01:54:53 2011] [error] [client 127.0.0.1] Compilation failed in require at C:/Utilities/UniServer/cgi-bin/awstats/awstats.pl line 19.\r

[Fri Apr 22 01:54:53 2011] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at C:/Utilities/UniServer/cgi-bin/awstats/awstats.pl line 19.\r

[Fri Apr 22 02:08:51 2011] [error] [client 127.0.0.1] Premature end of script headers: awstats.pl

[Fri Apr 22 02:08:51 2011] [error] [client 127.0.0.1] Encode object version 2.35 does not match bootstrap parameter 2.23 at C:/Utilities/UniServer/usr/lib/XSLoader.pm line 94.\r

[Fri Apr 22 02:08:51 2011] [error] [client 127.0.0.1] Compilation failed in require at C:/Utilities/UniServer/cgi-bin/awstats/awstats.pl line 19.\r

[Fri Apr 22 02:08:51 2011] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at C:/Utilities/UniServer/cgi-bin/awstats/awstats.pl line 19.\r

 

 

 

 

Version I used can be obtained from:

 

http://sourceforge.net/projects/miniserver....0_AWStats_1.0/

 

It installs a mini-version of Perl.

 

Just wondering can you get the simple “Hello World” page to display

 

http://localhost/cgi-bin/test.pl

 

All the best

Ric :(

Share this post


Link to post
Share on other sites

Same here.

When trying to install AWStats an Internal Server Error Occur

 

Downloaded AWStats PlugIn

http://sourceforge.net/projects/miniserver...Server_AWStats/

and extract to \UniServer also tried \UniServer\udrive\

 

Downloaded and Installed ActivePerl (ActivePerl-5.12.4.1205-MSWin32-x86-294981.msi) installed via:

\UniServer\a_install_perl\extract_install_perl.bat w/o issues

 

Left mouse click on UniTray, mouse over "Advanced" and select "Perl Shebang Update cgi-bin" - OK w/o issues

 

http://localhost/cgi-bin/test.pl - "Hello World" displays OK

 

http://localhost/cgi-bin/awstats/awstats.pl

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Can someone help?

 

And in the LOG files:

error.log

 

 

[Wed Jul 06 20:33:43 2011] [error] [client 127.0.0.1] Premature end of script headers: awstats.pl

[Wed Jul 06 20:33:43 2011] [error] [client 127.0.0.1] Can't locate strict.pm in @INC (@INC contains: C:/UniServer/usr/lib .) at C:/UniServer/cgi-bin/awstats/awstats.pl line 15.\r

[Wed Jul 06 20:33:43 2011] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at C:/UniServer/cgi-bin/awstats/awstats.pl line 15.\r

[Wed Jul 06 20:33:47 2011] [error] [client 127.0.0.1] Premature end of script headers: awstats.pl

[Wed Jul 06 20:33:47 2011] [error] [client 127.0.0.1] Can't locate strict.pm in @INC (@INC contains: C:/UniServer/usr/lib .) at C:/UniServer/cgi-bin/awstats/awstats.pl line 15.\r

[Wed Jul 06 20:33:47 2011] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at C:/UniServer/cgi-bin/awstats/awstats.pl line 15.\r

 

Thank you in advance!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...