Jump to content
The Uniform Server Community
er_1

access from internet problem

Recommended Posts

the following are the steps i have done in order to make the uniform server accessible from internet:

 

FYI: I still unable to make it works :) after following all instruction

 

1. After testing accessing the default index.php page from localhost successfully

 

2. I follow the instruction on this page

http://wiki.uniformserver.com/index.php/5...._Server_on-line (the putting server

on-line section) that ask me to modify some parameter of the .htaccess located inside the www folder

 

3. After that i run the server status program from uniformserver it said

-accessible from internet: NO.

 

4. to confirm the point number 3 problem, I try to access the ip address shown at the server status program,

it does not goes to the default index.php page, but instead i bring me directly to my router login page.

 

5. Then I setup/enable the port forwading (virtual server) in my dlink router DSL-520B with the follow input:

serverName: testweb

external port Start: 80

external port END: 80

protocol: TCP

internal port Start: 80

internal port END: 80

server ip address: 192.168.1.5

remote host: i leave this blank

 

6. I save and reboot both uniform server and the router

7. restarted uniform server

8. run the server status program, accessible from internet still says NO.

9. to confirm i type the ip address that is shown at the server status program into the browser and run it,

it still bring me to my router login page.

 

did I do anything wrong so far? why i am still unable to access uniform server from internet ?

 

Please help :)

 

Thanks,

 

Erik

Share this post


Link to post
Share on other sites

From a US point of view you are doing things correctly.

a] IP address displayed in the server status test is that seen from the Internet.

b] This IP address is used in the second test (Accessible from Internet) hence there is no need to retype it in your browser. Note: It is independent of what you set in the .htaccess file.

c] The .htaccess file allows users to see whats in folder www

 

Strange as this may seem it indicates your server is potentially accessible from the Internet.

9. to confirm i type the ip address that is shown at the server status program into the browser and run it,

it still bring me to my router login page.

The above points to an incorrect configuration of your router like the ports are not being forward to 192.168.1.5 which I assume is fixed.

 

I would recommend going to http://portforward.com/ where they provide detailed instructions for forwarding ports. I had a quick look and yours router is listed.

 

Perhaps one of our members use the same router and can guide you through it.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

From a US point of view you are doing things correctly.

a] IP address displayed in the server status test is that seen from the Internet.

b] This IP address is used in the second test (Accessible from Internet) hence there is no need to retype it in your browser. Note: It is independent of what you set in the .htaccess file.

c] The .htaccess file allows users to see whats in folder www

 

Strange as this may seem it indicates your server is potentially accessible from the Internet.

 

The above points to an incorrect configuration of your router like the ports are not being forward to 192.168.1.5 which I assume is fixed.

 

I would recommend going to http://portforward.com/ where they provide detailed instructions for forwarding ports. I had a quick look and yours router is listed.

 

Perhaps one of our members use the same router and can guide you through it.

 

All the best

Ric :)

 

Thanks for helping :)

 

If i am connected through internet with the following setup:

 

internet-> dsl modem/router -> wireless router -> my laptop.

 

where should i set the port forwarding ?

 

 

Thanks,

 

Erik

Share this post


Link to post
Share on other sites

I have tried using only the dsl/router -> laptop, it still does not work :) . window firewall in my laptop already turn off.

 

Please Help :).

 

Thanks,

 

Erik

Share this post


Link to post
Share on other sites

I have tried using only the dsl/router -> laptop, it still does not work :) . window firewall in my laptop already turn off.

 

Please Help :).

 

Thanks,

 

Erik

 

I can only imagine that you have given up on this issue as it's been since April and no one has responded. I hope that I don't have the same fate.

 

I'm new to using Uniform Server and cannot connect to the Internet. I have mimicked everything in this thread so far.

 

Can anyone provide suggestions with respect to verifying anything and/or confirming (settings/etc.) to resolve this issue.

 

My .htaccess file has been modified to comment out everything

My router, an SMCD3GN, has port 80 forwarded.

I've completley disabled any thing with the word firewall on my system

Share this post


Link to post
Share on other sites

Using a router usually will fail since the laptop is using DHCP (192.168.x.x) from your router.

You may test it with broadband connection (any direct internet connection), Uniserver should run fine.

Share this post


Link to post
Share on other sites

just try access it through internet from outside. I will accessible even if "run the server status program, accessible from internet still says NO."

Share this post


Link to post
Share on other sites

I have same issue, Server Status says it's not accessible form internet, but it is, just need to use another computer, because if I try to access it from same computer where server is, it doesn't work, so to sum up: server is not accessible from the internet on same machine where server is located (localhost), but it is accessible from other devices.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...