Jump to content
The Uniform Server Community
Middleman

Problem MySQL password change

Recommended Posts

Using Windows XP I have set up Joomla 1.5 on Uniform Server and set up for outside access to localhost.

 

It all works fine until I try to make it more secure by changing the MySQL password from "root" that was used during setup. I go into to Uniform Server through the admin panel and when I do the security check I can change all passwords without trouble except MySQL. When I cange that I cannot get into localhost but get this message:

"Database error: Unable to connect to database. Could not connect to MySQL"

 

The if I cange back to "root" password (and close and open my browser) everythink works again. For security with outside access I would like to be able to change this password. Is there another way to do it?

Share this post


Link to post
Share on other sites

I will assume after changing MySQL password from Apanel you can access the MySQL server using phpMyAdmin.

 

And typing this into a browser http://localhost/joomla/

Produces this error:

Database Error: Unable to connect to the database:Could not connect to MySQL

 

This means you installed Joomla before changing the password hence Joomla configuration is using password root.

 

Solution is to edit file:

UniServer\www\joomla\configuration.php

 

Look for this section:

/* Database Settings */
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = 'root';
var $password = 'root';
var $db = 'joomla';
var $dbprefix = 'jos_';

Change line:

var $password = 'root';

substitute root for your new password.

 

All the best

Ric ;)

Share this post


Link to post
Share on other sites

Hi Ric,

Sorry I missed your reply when it came out. Now that I know the cause and had a reason to reinstall Joomla and Uniform Server I changed my passwords before loading Joomla and it works out fine.

Thanks.

 

Tom

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...