Jump to content
The Uniform Server Community
Sign in to follow this  
masukica

Localhost is blank

Recommended Posts

Hey guys!

 

I've just downloaded UniformServer and unpacked it and launched it. But when I load anything - like phpmyadmin, or the control panel, or the perl script that's inside cgi-bin - nothing loads - it's just blank... And I don't really have a clue what could be wrong so I was wondering maybe you'd be able to point me into the right direction?

 

Many thanks!

Share this post


Link to post
Share on other sites

You have not stated which version of Uniform Server I will assume 5.5

 

Go to folder UniServer\a_diagnostic and read file Read_me.txt

 

Run the tests; see if they highlight any issues.

 

Do you get any response if you type http://127.0.0.1/ into a browser?

 

All the best

Ric ;)

Share this post


Link to post
Share on other sites

You have not stated which version of Uniform Server I will assume 5.5

 

Go to folder UniServer\a_diagnostic and read file Read_me.txt

 

Run the tests; see if they highlight any issues.

 

Do you get any response if you type http://127.0.0.1/ into a browser?

 

All the best

Ric ;)

 

Yes I should be using v 5.5 although on the About dialog it says 5.0 but the zip file is UniServer5_5.exe... My OS is Win7 64bit. After I run the server_status.bat here's what I get:

 

 

================== UNIFORM SERVER STATUS ==================

 

Your Internet IP Address = 217.174.62.14

Accessible from Internet = NO

Cron run status = Not running

PHP INI: php.ini file = Production

 

APACHE SERVER:

 

Apache port = 80

Apache SSL port = 443

Apache executable name = Apache.exe

Apache service name = ApacheS1

Apache SSL server = Disabled

Apache run status = Not running

Apache install status = Free to install

 

MySQL SERVER:

 

MySQL port = 3306

MySQL executable name = mysqld-opt.exe

MySQL service name = MySQLS1

MySQL run status = Not running

MySQL install status = Undefined!

 

PORT STATUS:

 

Apache port = 80 In use by another program.

Apache SSL port = 443 In use by another program.

MySQL port = 3306 Undefined!

 

 

 

1_port_check.bat:

 

 

Active Connections

 Proto  Local Address		  Foreign Address		State
 TCP	0.0.0.0:135			0.0.0.0:0			  LISTENING
 TCP	0.0.0.0:445			0.0.0.0:0			  LISTENING
 TCP	0.0.0.0:49152		  0.0.0.0:0			  LISTENING
 TCP	0.0.0.0:49153		  0.0.0.0:0			  LISTENING
 TCP	0.0.0.0:49154		  0.0.0.0:0			  LISTENING
 TCP	0.0.0.0:49155		  0.0.0.0:0			  LISTENING
 TCP	0.0.0.0:49156		  0.0.0.0:0			  LISTENING
 TCP	127.0.0.1:49165		127.0.0.1:49166		ESTABLISHED
 TCP	127.0.0.1:49166		127.0.0.1:49165		ESTABLISHED
 TCP	127.0.0.1:49167		127.0.0.1:49168		ESTABLISHED
 TCP	127.0.0.1:49168		127.0.0.1:49167		ESTABLISHED
 TCP	192.168.1.38:139	   0.0.0.0:0			  LISTENING
 TCP	192.168.1.38:139	   192.168.1.12:3589	  TIME_WAIT
 TCP	192.168.1.38:139	   192.168.1.12:3590	  TIME_WAIT

This test checks ports are free to use.
Scan down Local Address column
Look for any address ending with the following:

:80   (Apache standard port)
:443  (Apache standard SLL port)
:3306 (MySQL standard port)

Any entries found will prevent Uniform Server running

Disable any program using the above ports.
Generally Skype and IIS occupy port 80. Move Skype to another port, stop IIS se
rver.

Rerun test to ensure the ports are free (not listed)

Note 1: Press any key to rerun.
Note 2: To close this window click top right cross

Press any key to continue . . .

 

 

So when I run the 2_Apache_program.bat the server works... What does that mean, that I need to change some firewall settings or UAC?

 

 

EDIT: I think I've fixed the problem. I went on to Windows Firewall and deleted some rules for mysql and I think that made it work....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...