Jump to content
The Uniform Server Community
babyewok

phpmyadmin error

Recommended Posts

Hi,

 

I have has this problem before which came around all of a sudden and tried out lots of things that I googled, but nothing seemed to work until suddenly it all came back to life...not that I know why!

 

Basically, my database driven sites do not work and when I try to access phpmyadmin, I get this error:

 

phpMyAdmin - Error

Cannot load mysqli extension. Please check your PHP configuration.

 

I had previously updated php to a newer version 5.2.9, but everytyhing workes fine (except that my php includes stoppped working see my post: http://forum.uniformserver.com/index.php?showtopic=1793&hl= ://http://forum.uniformserver.com/inde...c=1793&hl= ). Maybe my efforts to get the includes to work screwed up phpmyadmin somehow???

 

I really need to get this working. I have version 4.0 Mona, PHP 5.2.9-2 and whatever PHPMyAdmin version came with 4.0 Mona. I know my UniServer version is a bit old - my next question would be how to upgrade, but first I want to get this working again.

Share this post


Link to post
Share on other sites

Hello,

Please try this..

 

Browse to: /usr/local/php/extensions or /ext

 

In there you should find, php_mysql.dll and php_mysqli.dll. If so proceed..

 

Open: /usr/local/php/php.ini

 

Find: extension=php_mysql.dll

Find: extension=php_mysqli.dll

 

Remove both semi-colons ( ; ) at the beginning of each line.

 

Reply if you have further problems.

 

Kalpz


ATOMIC Web Hosting 2007 - 2011

Shared Hosting - Reseller Hosting - Dedicated Servers - Virtual Private Servers (Request Dedicated/VPS Servers via E-mail)

E-mail: sales@atomicwebhosting.com Website: http://www.atomicwebhosting.com/

Share this post


Link to post
Share on other sites

I really need to get this working. I have version 4.0 Mona, PHP 5.2.9-2 and whatever PHPMyAdmin version came with 4.0 Mona. I know my UniServer version is a bit old - my next question would be how to upgrade, but first I want to get this working again.

 

The easiest and quickest way to resolve this problem is to actually upgrade your server. You may as well skip the fix step ;)

 

Download Uniform Server 5.5a Nano.

 

Put it in say, C:\55a\ (example)

Your existing will be C:\40\ (example)

 

Copy all files in C:\40\udrive\www\

Paste into C:\55a\www\

 

Copy all files in C:\40\udrive\usr\local\mysql\data\

Paste into C:\55a\usr\local\mysql\data\

 

Stop 4.0 server

 

Start 5.5a and you should be OK.

 

Kalpz


ATOMIC Web Hosting 2007 - 2011

Shared Hosting - Reseller Hosting - Dedicated Servers - Virtual Private Servers (Request Dedicated/VPS Servers via E-mail)

E-mail: sales@atomicwebhosting.com Website: http://www.atomicwebhosting.com/

Share this post


Link to post
Share on other sites

OK, so by copying C:\40\udrive\usr\local\mysql\data\, my databases will be copied?

 

I will have to look over for other little changes I made over time that I will have to redo - I know I installed that sendmail thing...anyway I'll let you know how it goes. Thanks for your help

Share this post


Link to post
Share on other sites

OK, so by copying C:\40\udrive\usr\local\mysql\data\, my databases will be copied?dmail thing...anyway I'll let you know how it goes. Thanks for your help

 

Yes that is correct. Try it out first to ensure your phpMyAdmin works. Then make your changes one at a time testing phpMyAdmin in between...

 

Good luck ;)


ATOMIC Web Hosting 2007 - 2011

Shared Hosting - Reseller Hosting - Dedicated Servers - Virtual Private Servers (Request Dedicated/VPS Servers via E-mail)

E-mail: sales@atomicwebhosting.com Website: http://www.atomicwebhosting.com/

Share this post


Link to post
Share on other sites

Hmm, I'm just thinking - another reason I had been slow to upgrade uniserver was because the current php version with it is 5.3. My reseller hosting uses 5.2.9 still, so that is what most of my clients will be using and therefore what I should really be testing in.

 

If I install the v5.5 of UniServer, would I be able to easily downgrade to php 5.2.9? And then of course, would I be back to the same problem I have now - or do you think the problem is more about my version of UniServer and phpmyadmin than php itself???

Share this post


Link to post
Share on other sites

Uniform Server 5.5a runs with PHP version 5.2.12. You shouldn't need to downgrade to 5.2.9.

 

Also - there is a configuration problem with PHP causing the phpMyAdmin to not work.. Do you have MSN or Yahoo? I could find the problem for you if you would like me to? you may PM me..

 

Kalpz


ATOMIC Web Hosting 2007 - 2011

Shared Hosting - Reseller Hosting - Dedicated Servers - Virtual Private Servers (Request Dedicated/VPS Servers via E-mail)

E-mail: sales@atomicwebhosting.com Website: http://www.atomicwebhosting.com/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...