Jump to content
The Uniform Server Community
Chris Hawkins

New Install - No phpmyadmin access AT ALL!

Recommended Posts

Hi,

 

I've just tried out Uniform Server for the first time and I've tried 5.4 and 5.4.1 beta2 and myphpadmin doesn't work for me either.

 

When I try to use Myphpadmin or change the password it just hangs and times outs after about a minute. Apache looks to work fine.

 

I'm running Windows 7 Professional and Firefox 3.5 and I'm starting the processes as standard programs and not services.

 

According to the server status mysql is running on the standard port and I can manually log into mysql and it looks to be working ok.

 

I'll gladly try out any suggestions you have.

Share this post


Link to post
Share on other sites

Hi Ollie222

 

From your post it looks as if both Apache and MySQL are running fine.

Can you try the following:

 

Close servers

From UniTray:

A] Advanced > Click on “php.ini switch to Development”

B] Start servers

C] Click “Admin Panel” – can you confirm this opens Admin in a browser?

D] Click “phpMyAdmin” – are any error messages displayed?

E] Server Information and logs > Click on “Apache error log” – are there any errors in the log

 

It may be a case sensitive issue

Can you type (copy) these addresses directly into a browser?

http://localhost/apanel/phpmyadmin/

http://localhost/apanel/phpMyAdmin/

 

What is displayed.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Hi Rik,

 

Thanks for the quick follow up, my answers are below.

 

Close servers

From UniTray:

A] Advanced > Click on “php.ini switch to Development”

OK

 

B] Start servers

OK

 

C] Click “Admin Panel” – can you confirm this opens Admin in a browser?

YES, this does open up the admin panel

 

D] Click “phpMyAdmin” – are any error messages displayed?

Same problem as before, it opens a browser, tries to connect for about 1 second (instead of being instant as most things are on a local machine), then the browser just says 'waiting for localhost'. After about a minute it just shows a blank page and says done.

 

E] Server Information and logs > Click on “Apache error log” – are there any errors in the log

[Fri Dec 04 21:48:48 2009] [notice] Apache/2.2.14 (Win32) PHP/5.3.1 DAV/2 configured -- resuming normal operations

[Fri Dec 04 21:48:48 2009] [notice] Server built: Sep 28 2009 22:41:08

[Fri Dec 04 21:48:48 2009] [notice] Parent: Created child process 6376

[Fri Dec 04 21:48:49 2009] [notice] Child 6376: Child process is running

[Fri Dec 04 21:48:49 2009] [notice] Child 6376: Acquired the start mutex.

[Fri Dec 04 21:48:49 2009] [notice] Child 6376: Starting 250 worker threads.

[Fri Dec 04 21:48:49 2009] [notice] Child 6376: Starting thread to listen on port 80.

 

It may be a case sensitive issue

Can you type (copy) these addresses directly into a browser?

http://localhost/apanel/phpmyadmin/

http://localhost/apanel/phpMyAdmin/

 

What is displayed.

The same as in D above

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

The file \home\admin\www\phpMyAdmin\index.php is being executed when I go to phpmyadmin and it runs up to the line

 

require_once './libraries/common.inc.php';

 

I think but I'm not 100% that it is then failing when it gets to

 

// Connects to the server (validates user's login)

$userlink = PMA_DBI_connect($cfg['Server']['user'],

$cfg['Server']['password'], false);

Share this post


Link to post
Share on other sites

Hi Ollie222

 

Ace result it looks like a configuration file issue.

 

Edit file:

UniServer\home\admin\www\phpMyAdmin\config.inc.php

 

At the top of this file delete this section its not required:

/**
* Sets the php error reporting - Please do not change this line!
*/
if (!isset($old_error_reporting)) {
error_reporting(E_ALL);
@ini_set('display_errors', '1');
}

Also delete this line:

#$cfg['PmaAbsoluteUri'] = $_SERVER['HTTP_HOST'] . '/apanel/phpMyAdmin/';

The # should have been //

 

Save the file and see if it works. Note close server and browser first and restart.

 

If that fails! Delete the following line:

$cfg['PmaAbsoluteUri'] = (!empty($HTTPS) ? 'https' : 'http') . '://' . $_SERVER['SERVER_NAME'] . (!empty($_SERVER['SERVER_PORT']) ? ':' . $_SERVER['SERVER_PORT'] : '') . substr($_SERVER['SCRIPT_NAME'], 0, strrpos($_SERVER['SCRIPT_NAME'], '/')+1);

Restart servers and browser and try again.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Hi Ric,

 

I've just tried all of the changes you've suggested above and stopped Apache and Mysql and restarted Uniserver and the browser and it's still the same issue as before.

 

I'm fairly new to using a WAMP installs, as I've always installed everything manually before, and only came across Uniserver after trying server2go and the phpmyadmin setup in that worked fine out of the box.

 

As a bit of feedback assuming we can get phpmyadmin up and working Uniserver looks to be a very nice bit of kit that very much simplifies some tedious tasks, so keep up the good work.

 

I'll check in a few times a day over the weekend so if you have any suggestions I'll gladly try them out for you promptly.

 

Cheers

 

Stu

Share this post


Link to post
Share on other sites

Hi Stu,

 

I have PM’ed two test files.

Give these a try; I will be interested in any feedback.

 

No its not a closed shop these will be included in beta3

Not sure if I will have time to publish this weekend.

Hence the quick post to Stu. :)

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

hi,

 

changing the password in the mysql cpanel U.S., as I have this message:

Warning: mysql_connect() [function.mysql-connect]: [2002] Une tentative de connexion a �chou� car le parti connect� n�a pa (trying to connect via tcp://localhost:3306) in C:\US_test1\UniServer\home\admin\www\mqsetup.php on line 61

Warning: mysql_connect() [function.mysql-connect]: Une tentative de connexion a �chou� car le parti connect� n�a pas r�pondu convenablement au-del� d�une certaine dur�e ou une connexion �tablie a �chou� car l�h�te de connexion n�a pas r�pondu. in C:\US_test1\UniServer\home\admin\www\mqsetup.php on line 61

Fatal error: Maximum execution time of 60 seconds exceeded in C:\US_test1\UniServer\home\admin\www\mqsetup.php on line 61

 

and still a blank page in phpmyadmin with w7 ultimate

 

@+

Share this post


Link to post
Share on other sites

Kris,

 

It seems there is something odd going on with uniserver, phpmyadmin and windows 7 and basically it's just not accessible, this sounds like your problem too.

 

Ric is trying to find a solution and hopefully it'll get sorted soon but so far he's had no joy.

Share this post


Link to post
Share on other sites

Same problem here - new install of v5.6.11-nano and phpmyadmin refuses to load.

 

I have run localhost servers for quite a few years and the older version of Uniform server worked fine but this version will simply not run phpmyadmin - at all - nothing, just a blank screen.

 

So, as the issue is not yet resolved is there a download available for the older version?

 

BTW I'm running Win7, Firefox and I've tried all the 'fixes' in this thread - no joy.

 

Grateful for advice - especially a quick fix as I've already spent far too much time trying to fix.

 

Thanks

 

Pete

Share this post


Link to post
Share on other sites

Same problem. UniServer Nano 5.7.0 running from USB stick on Win7.

The start page on localhost is displayed, I can enter apanel, but I can't access PhpMyAdmin:

Error

 

MySQL said: Documentation

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.

 

Errors:

 

110204 11:50:19 [Note]

110204 11:50:54 [Note] Plugin 'FEDERATED' is disabled.

110204 11:50:54 [Note] Plugin 'InnoDB' is disabled.

110204 11:50:54 [ERROR] MySQLS1: unknown variable 'default-character-set=latin2'

110204 11:50:54 [ERROR] Aborting

 

Maybe a file path in configuration somewhere is incorrect?

Share this post


Link to post
Share on other sites

Same problem. UniServer Nano 5.7.0 running from USB stick on Win7.

The start page on localhost is displayed, I can enter apanel, but I can't access PhpMyAdmin:

Errors:

Maybe a file path in configuration somewhere is incorrect?

 

With a freshly downloaded version of 5.7.1 extracted to my local drive phpmyadmin works perfectly out of the box for me.

 

Do you have an entry for

 

127.0.0.1 localhost

 

in your 'windows\system32\drivers\etc\hosts' file?

 

I'm running Win 7 64 bit with firefox

Share this post


Link to post
Share on other sites

Same problem. UniServer Nano 5.7.0 running from USB stick on Win7.

The start page on localhost is displayed, I can enter apanel, but I can't access PhpMyAdmin:

Errors:

Maybe a file path in configuration somewhere is incorrect?

I smell the Win 7 IPv6 Localhost problem.

Look at this post:

http://forum.uniformserver.com/index.php?showtopic=1789#

and also this Wiki entry:

http://wiki.uniformserver.com/index.php/5....o:_Known_Issues

 

Make sure you've got this aspect covered first and then look at MySQL configs if the problem still continues.

Regards,

BobS

Share this post


Link to post
Share on other sites

Same problem. UniServer Nano 5.7.0 running from USB stick on Win7.

The start page on localhost is displayed, I can enter apanel, but I can't access PhpMyAdmin:

Errors:MySQL said: Documentation

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.

Maybe a file path in configuration somewhere is incorrect?

With a freshly downloaded version of 5.7.1 extracted to my local drive phpmyadmin works perfectly out of the box for me.

 

Do you have an entry for

 

127.0.0.1 localhost

 

in your 'windows\system32\drivers\etc\hosts' file?

 

I'm running Win 7 64 bit with firefox

i had this same problem with windows xp with Uniform Server 5.7.4nano- and the error MySQL said: Documentation

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.

so i asked a friend of mine to help with it you should also make sure you are using a legal version of windows or you havent used a WGA patch that was a question that was asked to me if you do it will look something like this

127.0.0.1 localhost

 

#block wga

127.0.0.1 mpa.one.microsoft.com

if it does just remove the block wga and it should work and since mine didnt have that and it still didnt work :o

i let him remote to my computer and found there was 127.0.0.1 localhost and one other thing ;) but it still didnt work

however there is another fix he showed me that may work for you

 

Go To:

UniServer\home\admin\www\phpMyAdmin and open config.inc.php

Look for

$cfg['Servers'][$i]['host']		 = '127.0.0.1';	  // MySQL hostname or IP address

should be line 56 or close to it

and replace with

//$cfg['Servers'][$i]['host']		 = '127.0.0.1';	  // MySQL hostname or IP address
$cfg['Servers'][$i]['host']		 = 'localhost';	  // MySQL hostname or IP address

save and close then try to access phpmyadmin

 

hope this helps it worked for me :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...