Jump to content
The Uniform Server Community
Captain Black

doesn't on vista home premium sp1 (tur)

Recommended Posts

Hi,

 

I recently downloaded the uniform server file. than i pasted it in c:\

 

i ran start.exe, tray started, everything looks fine. than i run firefox, type localhost, and hit return, and it just doesn't work. what should i do?

 

i had xampp installed before, it was working fine, one day i turned my laptop on, it didn't work. just seconds ago i uninstalled it and got uniform instead. it doesn't work either :)

 

 

os: windows vista home premium service pack 1 (language: turkish)

computer: acer aspire 8920

 

thanks!

Share this post


Link to post
Share on other sites

Make sure you are logged into Vista as Admin.

Goto folder: C:\UniServer\alternative_control

Run: Start_Server.bat

 

What errors are reported?

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Make sure you are logged into Vista as Admin.

Goto folder: C:\UniServer\alternative_control

Run: Start_Server.bat

 

What errors are reported?

 

All the best

Ric :)

 

no errors are reported, cmd opens some stuff happen, it tells me to press any key, i press return, on firefox, a page opens that says uniform server, than it forwards me to http://localhost, it doesn't work

Share this post


Link to post
Share on other sites

OK Try Running Server status as follows:

1] Restart your PC, confirm you can brows the Internet

2] Navigate to folder: UniServer\unicon\main

3] Run server_status.bat

 

In the pop-up the top two lines will be similar to this

 

Your Internet IP Address = xxx.xxx.85.85

Accessible from Internet = NO

 

The last three lines:

Apache port = 80 Is free to use

Apache SSL port = 443 Is free to use

MySQL port = 3306 Is free to use.

 

What do you get after running this test?

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

test results show that apache is not running. but i have started Start.exe in uniform server directory, and than from the menu, i clicked "start apache" or sth like that, but i guess nothing happened...

 

fffxg.jpg

 

either i'm doing things wrong or windows is blocking the program. i will see if there's some blocking or sth like that.

 

any other sugestions?

Share this post


Link to post
Share on other sites

Interestingly I am working with Andrey to resolve an identical issue.

Originally I thought the problem was unique and specific to Andrey’s PC however the above image matches one I received from Andrey.

 

There are two problem areas. It looks like Xampp has not been completely removed.

Check in services for any running Apache or MySQL services and uninstall them.

 

Restart your PC and check there are no running Apache or MySQL services and or processes.

 

Extract a new copy of Uniform Server, navigate to folder UniServer\alternative_control

 

Use Start_Server.bat to start the servers and note any errors.

Use Stop_Server.bat to stop servers again note any errors.

 

Above should run the servers as a standard program.

 

Please post back and we will look at the second problem area.

 

All the best

Ric :rolleyes:

Share this post


Link to post
Share on other sites

Getting the same problem in Windows 7 Ultimate.

 

I had it working a couple of weeks back. but for some reason it still said the servers weren't running on the status screen... it still worked though, so I figured it was an issue with permission maybe... of fetching status data? but not necessarily the current real status of the processes.

 

Then I came to do some more Drupal development, and it seems as though the mysql/apache processes are not running nor showing on localhost, I've browsed the boards and taken the neccessary steps to troubleshoot, but it seems as though it may be something out of my grasp as this point.

 

I allowed full permissions for users for the entire folder, granted access via the firewall and my security systems in place (not many, as this is a new installation of win7ult).

 

I also dropped the services from services.msc and removed uniserver and re-installed it... no go!

 

I'm subscribing to this thread to get updates, and see any replies that request any information.

 

I got pretty much the same stuff to contribute as the original poster... not much different here after following the same steps. I can't even get the ports to free up now...

Share this post


Link to post
Share on other sites

Ok, so some more info I'd like to add and see if there's a solution before I switch solutions to something else (which I would unfortunately have to do, as this is starting to eat up time).

 

 

1) I'm on Win 7 Ult. x64.

2) Can't stop services.

3) Have to go to services.msc and manually stop services.

4) Ports are then free.

5) Sometimes restarting the servers this way still does not load any folders within localhost... so a subdirectory with drupal can be deleted and reinstalled a billion times and I can refresh and purge cache from the browser or whatnot, and it will still not be detected.

 

I have a strong feeling this has to do with

 

A) "run this program as an administrator" for individual processes.

:rolleyes: "run this program in Windows ******" Compatibility Mode.

 

Not a programmer by any means, But i've had similar issues with other stuff on Windows 7... just not sure what I should and shouldn't touch here..

Share this post


Link to post
Share on other sites

It really is difficult to pin point what the Issue is. I currently see two threads with a similar problem.

 

Majority of users do not have a problem however that is no excuse for not addressing a specific issue.

 

If you will bear with me I will add some additional diagnostics to 5.4, which I hope will pin point the cause.

 

We are currently testing PHP 5.3.1 hence little time to answer posts.

 

All the best

Ric :rolleyes:

Share this post


Link to post
Share on other sites

Generally most users do not have a problem. The forum is biased to users that due.

 

Anyway with the release of 5.4 it contains a folder named UniServer\a_diagnostic

Check out the file Read_me_first.txt follow the instructions it may help.

 

Hopefully your feedback will provide the team with a place to start with diagnosing this issue.

 

All the best

Ric. :rolleyes:

Share this post


Link to post
Share on other sites

Generally most users do not have a problem. The forum is biased to users that due.

 

Anyway with the release of 5.4 it contains a folder named UniServer\a_diagnostic

Check out the file Read_me_first.txt follow the instructions it may help.

 

Hopefully your feedback will provide the team with a place to start with diagnosing this issue.

 

All the best

Ric. :)

 

I have a windows 7 machine with the same exact issue. any ideas yet on this one?

Share this post


Link to post
Share on other sites

Uniform Server 5.5-Nano has just been released.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

OK First download, a new copy of 5.5-nano (publish date 2009-12-13)

Create a new folder C:\Nano_5_5

Extract Uniform Server to this folder

Can you work through tests in folder UniServer\a_diagnostic

They may throw some light on the problem you are having

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

OK First download, a new copy of 5.5-nano (publish date 2009-12-13)

Create a new folder C:\Nano_5_5

Extract Uniform Server to this folder

Can you work through tests in folder UniServer\a_diagnostic

They may throw some light on the problem you are having

 

All the best

Ric :)

 

everything looks ok up until test 5 were I get an error. the error report reads:

 

 

 

 

 

=== 1) INSTALL RUN MYSQL SERVICE =========================================

 

Expected results:

 

You may be challenged by your firewall ALLOW access

Run 1_port_check.bat confirm port 3306 is now in use

 

Press any key to run MySQL Service

 

Press any key to continue . . .

 

=== Error Report =========================================================

 

Install/Remove of the Service Denied!

The service name is invalid.

 

More help is available by typing NET HELPMSG 2185.

 

 

===================================================== END Error Report ===

Press any key to continue . . .

 

=== 2) MySQL SERVER CHECK ===============================================

 

The following test runs a SQL query on the MySQL server

 

 

=== Epected results similar to this ======================================

 

Connection id: 12

SSL: Not in use

Using delimiter: ;

Server version: 5.1.41-community MySQL Community Server (GPL)

Protocol version: 10

Connection: localhost via TCP/IP

Client characterset: utf8

Server characterset: utf8

TCP port: 3306

Uptime: 39 min 10 sec

Threads: 1 Questions: 43 Slow queries: 0 Opens: 15 Flush tables: 1 Open tab

les: 0 Queries per second avg: 0.18

--------------

Database

information_schema

mysql

phpmyadmin

 

==========================================================================

 

To run test Press any key

Note: You may be challenged by your firewall ALLOW access

 

Press any key to continue . . .

 

=== Actual results =======================================================

ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)

==========================================================================

 

Press any key to continue . . .

 

=== 3) INSTALL RUN APACHE SERVICE ========================================

 

Expected results:

 

You may be challenged twice by your firewall ALLOW access

Run 1_port_check.bat confirm port 80 is now in use

 

Press any key to run Apache Service

 

Press any key to continue . . .

 

=== Error Report =========================================================

 

Installing the ApacheS1 service

(OS 5)Access is denied. : Failed to open the WinNT service manager

The service name is invalid.

 

More help is available by typing NET HELPMSG 2185.

 

 

===================================================== END Error Report ===

 

Press any key to continue . . .

Share this post


Link to post
Share on other sites

I think the issue is User Account Controls (UAC)

 

You must be logged in as Admin

Run batch files 5_Start_Services.bat and 6_Stop_Services.bat using the following method: right-click and select "Run as administrator"

 

If that fails temporarily disable User Account Control

 

Disable UAC on Windows Vista

a) Open up Control Panel, type in “UAC” into the search box.

:) You will see a link for “Turn User Account Control (UAC)

on or off” click this link:

c) A new screen opens uncheck the box for “Use User Account Control (UAC)”,

click the OK button.

d) You must restart Windows.

 

Disable UAC on Windows 7

a) Type UAC into the start menu or Control Panel search box.

:) Drag the slider up or down, defines how often you want to be alerted.

c) Drag it all the way down to the bottom, this disables UAC entirely.

 

Run service batch files again does that resolve the problem?

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Ric is correct that the problem lies with UAC and permissions.

 

There are a couple of simple ways around it and previous post shows a way around it.

 

In my opinion the simplest way of getting Uniserver up and working on Windows 7 and I presume the same will apply for Vista is by doing as follows.

 

1. Download 'UniServer5_5.exe' to your machine.

 

2. Run 'UniServer5_5.exe' and choose a location to extract it to.

 

3. Go to the location you chose to extract Uniserver to and open the 'Uniserver' folder.

 

4. Right click on 'Start.exe' and select 'Run as administrator'.

 

5. Right click on the system tray icon and select Install and run all services.

 

After a couple of seconds Apache and Mysql should now run as expected.

 

 

If you really want to be lazy and are happy to always grant Uniserver 'Run as administrator' privileges then you could also

 

1. Right click on 'Start.exe' and choose 'Properties'

 

2. Click the compatibility tab.

 

3. Tick the box 'Run this program as adminstrator'.

 

Now in future you can just run 'Start.exe' as normal by double clicking it and it will always automatically be run as an adminstrator.

 

 

You only need to do the above if you want to install apache and mysql as a server. If you want to just use them as a normal program then there is no issue and you don't need to run as administrator, you can just choose to run them as standard programs by left clicking on the system tray icon and selecting 'Start Uniserver'.

 

I hope this helps.

 

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...