Jump to content
The Uniform Server Community
Sign in to follow this  
SteP

Nano_5_1: UniTray no start from junctioned folder

Recommended Posts

Hi, has anyone tried running Nano_5_1 Start.exe from a junctioned folder? It fails starting UniTray1.exe without any error message.

 

Reproduce by:

- download uniserver 5.1 main zip file, unpack into folder v:\test. no perl or addons necessary, just the zip file

- create a junction (use sysinternal's junction.exe or other tools) from C:\Nano_5_1\UniServer to v:\test\UniServer

- go to to C:\Nano_5_1\UniServer and run Start.exe => UniTray not started

- now go to V:\test\UniServer and run Start.exe => UniTray started (OK)

 

Here V:\ is a substituted drive (SUBST.EXE V: J:\APP) but I don't think that matters, I think only the junction matters.

 

platform: uniserver 5.1, Windows XP Pro SP3

 

edit: I tried running Start_UniTray.bat directly in a similar setup. It also silently fails starting UniTray1.exe.

Share this post


Link to post
Share on other sites

When servers are run current path is checked against what’s in the following file:

UniServer\unicon\main\location_tracker.txt

If different all absolute paths are rewritten to the current path and tracker file updated accordingly.

 

Above explains the results you are observing.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

When servers are run current path is checked against what’s in the following file:

UniServer\unicon\main\location_tracker.txt

If different all absolute paths are rewritten to the current path and tracker file updated accordingly.

 

Above explains the results you are observing.

Hmm, how does it explain why Start.exe fails starting UniTray1.exe? I don't get it.

 

However, this info does help me to understand the other issue I reported regarding my out-of-the-box experience. Suggestion: add the contents of location_tracker.txt to the informative output of UniTray 'Server Status' entry. That would help diagnose startup issues like the ones I described in another thread.

Share this post


Link to post
Share on other sites

Hi, has anyone tried running Nano_5_1 Start.exe from a junctioned folder? It fails starting UniTray1.exe without any error message.

 

Reproduce by:

- download uniserver 5.1 main zip file, unpack into folder v:\test. no perl or addons necessary, just the zip file

- create a junction (use sysinternal's junction.exe or other tools) from C:\Nano_5_1\UniServer to v:\test\UniServer

- go to to C:\Nano_5_1\U new jersey asian escort niServer and run new jersey asian escorts Start.exe => UniTray not started

- now go to V:\test\UniServer new jersey escort and run Start.exe => UniTray new jersey escorts started (OK)

 

Here V:\ is a substituted drive (SUBST.EXE V: J:\APP) but I don't think that matters, I think only the junction matters.

 

platform: uniserver 5.1, Windows XP Pro SP3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...