Jump to content
The Uniform Server Community
Gian_Krl0

PHP4 with CURL?

Recommended Posts

I want to use my installation of Uniform Server 3.2 with my ADSL connection and the service of StacticDNS of DynDNS.com, for serve scripts in PHP4 (I've installed PHP4 plug-in).

 

But this scripts need to have PHP4 with CULR enabled, I see in PHPinfo and I not view signs of CURL.

 

Please, how I can install CURL and enable this for PHP4 in Uniform Server 3.2 ?

 

Thank you very much in advance!

 

*excuse me by my bad english*

Share this post


Link to post
Share on other sites

If you pick up the PHP4 package (same version you're using) from php.net -

http://dk2.php.net/get/php-4.3.11-Win32.zip/from/a/mirror -

and in this file, find

php-4.3.11-Win32.zip\php-4.3.11-Win32\extensions\php_curl.dll

and copy this to your

W:\usr\local\Php\extensions\

folder, you'll have curl available in PHP AFAIK.

 

Last step is enabling it in php.ini - just find the line

;extension=php_curl.dll

in W:\usr\local\Php\php.ini and remove the leading ; (comment-tag).

Restart Apache, and curl should work. I hope.

 

:P And version # fixed to 4.3.11 Olajide

Share this post


Link to post
Share on other sites

Thanks by your help!

 

But to obtain that it works I had to copy two archives associated to php_curl.dll, these come in PHP's package: ssleay32.dll and libeay32.dll

 

According to install.txt (inside of php-4.3.11-Win32.zip), these two archives must be copied in two places:

W:\usr\local\Php\

W:\usr\local\Php\dll\

 

After this, CURL appears like activated in PHPinfo.

Now, I hope that it works without problems :P

 

Again, thank you very much.

Share this post


Link to post
Share on other sites

I'm a really unexperienced and uninformed user so excuse me if I'm overlooking something obvious.

I come from the Flash community and trying to run amfphp but I need curl to do so.

I'm on Uniform Server 3.3 with PHP 5.1.1

I have tried the previous method but I get the following message:

"Unable to load dynamic library '/usr/local/PHP/extensions\php_curl.dll" although the file is in that path.

I suppose this is because the file comes from PHP 4.3.11

Do I need to downgrade to PHP4 for CURL to work?

 

Much thanks

Share this post


Link to post
Share on other sites

Hi, AlleyKat.

 

Can you expand a bit on how to get curl running with the latest Uniform Server (PHP 5.1.1) please?

 

I downloaded the archive you specified but it didn't contain any curl-related fies that I could see.

 

 

No, find CURL for php5:

http://dk.php.net/get/pecl-5.1.1-Win32.zip/from/a/mirror

2705[/snapback]

Share this post


Link to post
Share on other sites

Download PHP 5.1.1 from here: http://www.php.net/releases.php and find the extention in there. Make sure i got the version right.

 

Direct Link: http://www.php.net/get/php-5.1.1-Win32.zip/from/a/mirror or ifnot in that one, try http://www.php.net/get/pecl-5.1.1-Win32.zip/from/a/mirror

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...