Jump to content
The Uniform Server Community
supernovice

Uniform Server on Windows Server 2003

Recommended Posts

I have been reading a few posts mentioned about transferring their tested site to another live server.

 

But for me, I would prefer using my own HP ML110 with Windows Server 2003 R2, hosting live right under my desk. However, I'm a bit lost technically when come to this.

 

In overall, this Uniform Server will be hosting probably 3 services:

1. a family Forum

2. a small webmail

3. an e-commerce site! (for case study & tutorial use)

 

What are the criteria to make a Uniform Server go live?

- Allowing external access in .htaccess

- a good DSL connection (well, I believe that doesn't really matter, as it is for family use)

 

Hmm, what else? Let's see...

- How about the setting in apanel? Anything should I take note?

- How about domain name? (if not, how about NO-IP or dynDS, are they applicable?)

 

Your advise is greatly appreciated!

 

Cheers,

Share this post


Link to post
Share on other sites

just install it. thats all thats needed.

 

at least win2000, 500Mhz, 250mb ram, 80mb harddisk (~50 is uniform server), ISDN is the minimum you should supply (ISDN: only 5 fast users at a time for websites+pictures).

- 250MB Ram are pretty much used up by apache+mysql- if the os is using a pagefile, (like windowsOs, 90 MB are sufficient), or for a multithreading-dos use a qemm manager to extend RAM to harddrive. for less then 50 syncronous connections ok.

 

(I had Uniform Server running on a PSP, yes - playstation portable (350-turbomode500mhz), server on SD card, with a freedos port...)

 

if its for lan use only, thats all you need.

 

if you want it to be accessable from inet, forward port 80 (TCP) to the ip of you pc hosting UniServer.

 

note, your IP will change after 24 hrs (DSL users). so use dyndns to get a domain name like yourname.ath.cx / yourname.kicks-ass.net or alike (forum: http://forum.uniformserver.com/index.php?s...1&hl=dyndns -use inadyn ). my post at the bottom will show you how to tie it to a yourname.de.vu or alike.

 

thats how i use it.

 

MAKE SURE, ControlPanel->IIS is turned off, or the IIS port is changed from 80 to something else!!!

Share this post


Link to post
Share on other sites

just install it. thats all thats needed.

 

at least win2000, 500Mhz, 250mb ram, 80mb harddisk (~50 is uniform server), ISDN is the minimum you should supply (ISDN: only 5 fast users at a time for websites+pictures....

 

All right, thanks for the clue.

I'll give it a try. :D

Share this post


Link to post
Share on other sites

still you should log into the admin panel and make sure you check it out to know what you can set up and stuff. (also security related features)

 

you're welcome

Share this post


Link to post
Share on other sites

still you should log into the admin panel and make sure you check it out to know what you can set up and stuff. (also security related features)

 

you're welcome

 

 

After some studying & testing. I was able to access apanel through Internet with NO-IP service. Due to my ISP restriction on port 80, I switched from 80 to 81 instead, which is: http://mydomain:81

 

However, there's another problem - Wordpress. The installation was done at 'wordpress' folder which was accessible at http://localhost/wordpress. After the port switch, the live test at my remote browser returned 'page no found'. I have tried http://mydomain:81/wordpress & http://mydomain/wordpress.

 

Please point out the possible factor of this scenario.

 

Thank you,

 

:D

 

 

p/s: please bear in mind the URL provided are examples.

Share this post


Link to post
Share on other sites

first of all:

you MUST use :81 if did set up UniServer to use this port. (:80 is the default, if you don't type it in) So if your ISP blocks it completly switching to 81 is adviceable. otherwise redirect the user from port 80 to 81 (if :80 throttled or something).

 

now, if you server is configured correcly, dns of your domainname hoster is updated, http://yourdomain.tld:81/ should work. this is what you should test first:

 

This is written a little general, to help others sorting things out...

 

http://yourdomain.tld:81/ does not work, why?

 

(it is assumed that "localhost" [the used at the same computer you use for testing and UniServer is run at] is the LAN internal address to the PC where UniServer is started. if not use its LAN IP or hostname/computername)

 

if localhost:81 does not work,

  • your server does not run (taskmanager - apache.exe is listed?),
  • or is misconfigured (runs but does not catch connections, try localhost:80)
  • or is blocked by your software firewall (for WinXP internals to work properly, you must upgrade to SP2)

if http://yourdomain.tld:81/ does not work, but http://localhost:81 does,

  • you did not update your DYNAMIC DNS with your IP (most ISPs change the clients IPs every 24 hrs, unless you have a static IP)
  • your router is not configured in "PORT FORWARDING" (<- not special apps or alike) to route the port :81 to your internal specific IP and port 81. (e.g. IP=192.168.0.101 EXTERNAL_PORT=81 INTERNAL_PORT=81 PROTOCOL=TCP / this is where you could change the external port 81 to internal 80 without reconfiguring UniServer)

if your http://localhost:81/ works but not http://localhost:81/wordpress/, you have either:

  • a redirect/blocking in place that does not allow to access any subfolders (has to be installed, is not a default)
  • not installed wordpress within the .\www folder
  • misspelled either the http://..../wordpress or .\www\wordpress foldername

hope i didn't miss anything, enjoy

Share this post


Link to post
Share on other sites

...

if your http://localhost:81/ works but not http://localhost:81/wordpress/, you have either:

  • a redirect/blocking in place that does not allow to access any subfolders (has to be installed, is not a default)
  • not installed wordpress within the .\www folder
  • misspelled either the http://..../wordpress or .\www\wordpress foldername

hope i didn't miss anything, enjoy

 

This is my case.

Factor (2), it's inside the correct folder, because before port-switch, my work on WP is done within a LAN, it was accessible without problem via http://localhost/wordpress.

 

Factor (3), I guess this is not happening... otherwise, I won't be able to access apanel, meanwhile wordpress is just a word '/wordpress' to add into URL..

 

...

 

I believe factor (1) is causing all the trouble! Last night I tested again the server with port 80 (in LAN environment), everything went ok! Even WP is accessible...

 

...

 

ok, let's see...

A redirect or blocking is in place... which could it be?

I have examined 2 channels:

Internet, domain by NO-IP

http://mydomain.no-ip.info:81/wordpress [failed]

LAN

http://serverIP:81/wordpress [failed]

Localhost

http://localhost:81/wordpress [failed]

 

 

Looks like the redirect or blocking is happening at the server itself, right?

Correct me if I'm wrong, I'm googling for redirect/block in Windows Server 2003 R2 now...

 

Thanks!

Share this post


Link to post
Share on other sites

i forgot to mention IIS (microsofts web server. has to be turned off or port changed.)

 

try to be more specific. i think i figured out that you dont even get to point 1: localhost:81 doesn't work.

 

so what are you telling me?

its not accessible trough lan? not by :80 and not by :81? apache process is running?

then you probably didn't change all places in apaches config to port 81.

if apache.exe is not in tasklist, you have a config error.

 

test apache config: %apachepath%bin\Apache.exe -f %apachepath%conf\httpd.conf -S

 

enter the correct path within %apachepath%.

 

apache settings needed:

line: text

124: Listen 81

 

285: ServerName localhost:81

 

979: NameVirtualHost *

980: <VirtualHost *>

981: ServerName localhost:81

982: DocumentRoot /www

983:</VirtualHost>

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...