Jump to content
The Uniform Server Community
Sign in to follow this  
Han

Problem creating image with text

Recommended Posts

The following script works with Uniserver3_2a, but fails with Uniserver3_5

Error messages says that the font file is missing.

Where can I get a font file and what is the location I have to put it?

 

Thanks,

Han

 

++++++++++++++++++++++++++++

function vertText($text, $id)

{

// Create the image

$im = imagecreatetruecolor(20, 80);

 

$background = imagecolorallocate($im, 253, 208, 23);

$black = imagecolorallocate($im, 0, 0, 0);

imagefilledrectangle($im, 0, 0, 19, 79, $background);

 

$font = 'arial.ttf';

 

// Add the text

imagettftext($im, 12, 270, 5, 5, $black, $font, $text);

 

// Create the image with vertical text

imagepng($im, "$id.png");

imagedestroy($im);

}

Share this post


Link to post
Share on other sites

You need to supply a path for the font.

 

If using this : $font = 'arial.ttf'; copy the font to the folder where your script is located.

 

Alternatively change the line to $font = 'C:\WINDOWS\Fonts\arial.ttf';

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Putting a copy of the arial.ttf from c:\windows\fonts in the scripts folder has the effect of not showing an error message. But the created image contains no text.

Any explanation why uniserver3_2a does not need a font file in the script folder?

I searched php.ini for a font directory, I searched the uniserver3_2a directory tree for font files, but I found nothing. Where is 3_2a getting the font definition? Is 3_5 doing things differently?

Thanks,

Han

Share this post


Link to post
Share on other sites

As RIC said, the only thing you need is

$font = 'C:\WINDOWS\Fonts\arial.ttf';

and copying the font to your script is not need.

 

works fine. tested with the fresh uniformserver 3.5.

 

ps: if you have the png file already please delete it first and test again.

Share this post


Link to post
Share on other sites

Hi there,

 

The problem is that the var $FontName (or $this->FontName) of the pChart-class is initiated as NULL. Unless you change that value by using setFontProperties, this NULL is used as the path to that ttf-file.

 

So please set this by using for example:

$mychart->setFontProperties("Fonts/pf_arma_five.ttf",12).

 

It worked for me

 

O I'm sorry, I tought that this was about pChart, because it also uses imageftbbox. I just couldn't delete this answer. So don't mind.

Share this post


Link to post
Share on other sites

Hi,

First of all,you copy the font where your script is situated.

 

 

 

 

 

_______________________________

"Want to get-on Google's first page in 48 hours and flood your site with traffic?

Try Traffic Geyser, the internet's #1 video marketing software at Traffic Geyser "

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...