Jump to content
The Uniform Server Community
Sign in to follow this  
angus203

How to config CGI

Recommended Posts

#!/usr/bin/perl
print "Content-Type: text/plain", "\n\n";
print "Hello World in Perl", "\n";

 

http://localhost/cgi-bin/test.cgi
it has Internal Server Error

 

http://localhost/cgi-bin/
Forbidden
You don't have permission to access /cgi-bin/ on this server.

 

how to run cgi?

Share this post


Link to post
Share on other sites

internal server error shows you have a problem with your apache configuration file(httpd.conf).

 

the original uniform server has no problem running your code.

 

open your httpd.conf(/udrive/usr/local/apache2/conf/httpd.conf) and check your cgi-bin configuration.

it should much like

 

ScriptAlias /cgi-bin "/cgi-bin/"

# "C:/Program Files/Apache Group/Apache2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.

<Directory "/cgi-bin/">
 AllowOverride All
 Options ExecCGI
</Directory>

 

BUT if you have no problem with your first page of uniform server and can shutdown your server using your admin panel page then there might be another problem. check your apache log file also.

Share this post


Link to post
Share on other sites

this is default setting

ScriptAlias /cgi-bin "/cgi-bin/"

# "C:/Program Files/Apache Group/Apache2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.

<Directory "/cgi-bin/">
 AllowOverride All
 Options ExecCGI
</Directory>

<Directory "/home/admin/www/cgi-bin/">
 AllowOverride All
 Options ExecCGI
</Directory>

 

i have deleted the .htaccess file and enabled "AddHandler cgi-script .bat .exe .pl .cgi"

finally no work...

what problem?

Share this post


Link to post
Share on other sites

I deleted my last post answered the wrong question. :)

 

Deleting .htaccess prevents running CGI scripts in www and its sub-folders.

 

Any scripts in cgi-bin will run with the defaults you have shown.

 

It would be interesting to see if the error log file provides a clue to the problem.

Before running the servers open error.log located in \Uniform Server\udrive\usr\local\apache2\logs delete it’s content. Save and run the servers, access your script. Now check the log file for errors.

 

What do you get?

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

I deleted my last post answered the wrong question. :)

 

Deleting .htaccess prevents running CGI scripts in www and its sub-folders.

 

Any scripts in cgi-bin will run with the defaults you have shown.

 

It would be interesting to see if the error log file provides a clue to the problem.

Before running the servers open error.log located in \Uniform Server\udrive\usr\local\apache2\logs delete it’s content. Save and run the servers, access your script. Now check the log file for errors.

 

What do you get?

 

All the best

Ric :)

 

Error log

[Sun Jul 06 08:55:49 2008] [error] [client 127.0.0.1] attempt to invoke directory as script: W:/cgi-bin/
[Sun Jul 06 08:55:54 2008] [error] [client 127.0.0.1] script not found or unable to stat: W:/cgi-bin/index.cgi

Share this post


Link to post
Share on other sites

does test.cgi exist in "/udrive/cgi-bin" folder? the error log says you do not have the script file in "/udrive/cgi-bin" folder.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...