Jump to content
The Uniform Server Community
Sign in to follow this  
newuser

Cannot access the server from another pc on same network

Recommended Posts

Hello I have installed Uniform Server it works on local pc but I cannot access from another pc within the same network (the other pc is just 1 meter from the first one :) ).

 

On the same pc I have Oracle Express Server installed and I can access it through local network without any problem so it doesn't come from the pc or network but from the Apache config file and I'm at lost with it.

 

Can someone help me ?

 

Thanks.

Share this post


Link to post
Share on other sites

I was wondering if you have put UniServer on-line!

 

Open the file .htaccess in folder www and make sure these lines are commented as shown:

 

# This file provides security to the server limiting access to the localhost only.

# Comment to deactivate.

 

#Order Deny,Allow

#Deny from all

#Allow from 127.0.0.1

 

 

I forgot to mention you do need to use the IP address of the machine that your server is running on.

 

To find your IP address:

Open a command prompt: start>run type in cmd

In the window that pops-up type: ipconfig

 

You will see something that looks like this:

 

Ethernet adapter Connection:

Connection-specific DNS Suffix . :

IP Address. . . . . . . . . . . . : 192.168.1.6

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.1.1

 

Use the ip address found as follows:

On the other machines to access your webserver type http://192.168.1.6/

 

If you changed the port number to say 8080 you would type http://192.168.1.6:8080/

 

All the best

Ric

:)

Share this post


Link to post
Share on other sites

Thanks a lot it now works :(

 

But there's something strange: it works with Internet Explorer 7 but not with Firefox 2.0.0.11 : on Firefox it lasts forever. It's irrational no :)

 

Even on IE my wordpress install which does work locally doesn't work from the other pc: error message says Internet Explorer cannot display the webpage.

Share this post


Link to post
Share on other sites

I have a partial solution, works in IE but not Firefox :)

 

Login in to Wordpress admin. Click options > General

 

Scroll down the page until you will find the following lines:

(blog will probably be wordpress unless you used a different folder)

 

WordPress address (URL): http://localhost/blog

Blog address (URL): http://localhost/blog

 

Use the IP address you found (see my last post) and replace the localhost to give:

 

WordPress address (URL): http://192.168.1.6/blog

Blog address (URL): http://192.168.1.6/blog

 

To access wordpress type the following into your browser address bar (that’s any pc including the pc where wordpress is installed):

 

http:// 192.168.1.6/blog/ (note: replace blog with wordpress or whatever folder name you use)

 

Firefox for whatever reason reverts back to localhost. I have no idea why this happens. Does anyone have any thoughts on this?

 

All the best

Ric :(

Share this post


Link to post
Share on other sites

Hi,

I've got similar issues with UniformServer...on local intranet..

 

I've got my other PC's to connect to webpage through browser to joomla website, by commenting those access permission lines in .htacess file on server, BUT:

 

1. All my Joomla webpage links are referenced to localhost and not the PC name or IP, so i can only view hompage.

 

2. Both Firefox and IE7 only shows the text of the homepage and not any graphics or conrols??

 

Please help me bro, it's a website for people at work in our business unit?

Share this post


Link to post
Share on other sites

Hi,

I've got similar issues with UniformServer...on local intranet..

 

I've got my other PC's to connect to webpage through browser to joomla website, by commenting those access permission lines in .htacess file on server, BUT:

 

1. All my Joomla webpage links are referenced to localhost and not the PC name or IP, so i can only view hompage.

 

2. Both Firefox and IE7 only shows the text of the homepage and not any graphics or conrols??

 

Please help me bro, it's a website for people at work in our business unit?

 

 

:)

 

solved it myself - you have to install Joomla with MySQL user that allows any host = %

 

and then during Joomla webpage installation you need to set your host to : IP of server and also your link of livesite to

http://IP of server/jooml website directory...

 

then i use uniformserver to simulate joomla on windows xp and all works fine :(

Share this post


Link to post
Share on other sites

I have a partial solution, works in IE but not Firefox :)

 

Login in to Wordpress admin. Click options > General

 

Scroll down the page until you will find the following lines:

(blog will probably be wordpress unless you used a different folder)

 

WordPress address (URL): http://localhost/blog

Blog address (URL): http://localhost/blog

 

Use the IP address you found (see my last post) and replace the localhost to give:

 

WordPress address (URL): http://192.168.1.6/blog

Blog address (URL): http://192.168.1.6/blog

 

To access wordpress type the following into your browser address bar (that’s any pc including the pc where wordpress is installed):

 

http:// 192.168.1.6/blog/ (note: replace blog with wordpress or whatever folder name you use)

 

Thanks a lot it works.

 

Firefox for whatever reason reverts back to localhost. I have no idea why this happens. Does anyone have any thoughts on this?

 

All the best

Ric :(

 

Happily my intranet users use IE. But I do use Firefox : is it a firefox bug ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...