Jump to content
The Uniform Server Community
Alan

slimftp - directory listing not retrieved

Recommended Posts

Hi,

 

I'm running slimftp.

 

When I log in via filezilla 3.0.3, it gets past username and password, until

 

"Command: LIST

Response: 150 Opening passive mode data connection for listing of "/".

Response: 425 Can't open data connection.

Error: Failed to retrieve directory listing

"

 

I've created the directory c:\ftproot

 

<User "bob">

Password "abc123"

# Mount / C:/ftproot

Mount / w:/

Allow / All

</user>

 

I've also tried w:/ and c:\ftproot

 

but filezilla can't seem to retrieve a directory listing.

 

I've checked the logs but slimftp doesn't say anything about not being able to retrieve the directory.

 

Any suggestions?

 

Many thanks

Alan

Share this post


Link to post
Share on other sites

Password "abc123"

# Mount / C:/ftproot

Mount / w:/

Allow / All

 

It looks as if it’s basically working!

Have you tried setting Filezilla to passive mode?

 

1) Click Edit, Settings in top menu bar, open dropdown menu select settings.

2) Select Firewall Settings, just underneath Connections (menu on left)

3) In new page, check the box named Passive Mode

4) Click OK:

 

I think it’s a firewall issue (not sure)

 

All the best

Ric :P

Share this post


Link to post
Share on other sites

Hi Ric,

<User "bob">

Password "abc123"

# Mount / C:/ftproot

Mount / w:/

Allow / All

</user>

 

It looks as if it’s basically working!

Have you tried setting Filezilla to passive mode?

 

1) Click Edit, Settings in top menu bar, open dropdown menu select settings.

2) Select Firewall Settings, just underneath Connections (menu on left)

3) In new page, check the box named Passive Mode

4) Click OK:

 

I think it’s a firewall issue (not sure)

 

All the best

Ric :P

Thanks for that. Because I 'got through' to the ftp program, I thought the firewall was OK. Plus I did have to allow slimftp to through the firewall saying it required access.

 

But I then checked the firewall logs 'comodo firewall', and found it was blocking access from the remote computer to port 4738?

 

I disabled the firewall and it worked. I re-enabled the firewall, allowed remote source ip and it worked.

 

Many thanks for your help

Alan

Share this post


Link to post
Share on other sites

Ace and thanks for the feedback. :P

All the best

Ric :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...