Jump to content
The Uniform Server Community
Sign in to follow this  
madencbm

InnoDB enable

Recommended Posts

I have an Error installing core module for gallery2. This is the download from gallery2 website (http://gallery.menalto.com/downloads). This is the first step toward installing the Drupal module for inserting gallery2 (http://drupal.org/project/gallery)

 

The response from gallery2 forum:

"It looks like your mySql database is not set up properly. You need to enable the 'InnoDB' feature in the database that you are tyring to create."

 

In phpMyAdmin; MyISAM is default and don’t see how to change to InnoDB

also "InnoDB has been disabled for this MySQL server."

 

Question:

 

1).How do I enable InnoDB engine?

 

2). Is there a way to use gallery2 with MyISAM?

 

Thanks for your help,

Chris

Share this post


Link to post
Share on other sites

1).How do I enable InnoDB engine?

Shutdown the servers.

Got to folder:

*\Uniform Server\udrive\usr\local\mysql\bin

Open the file my-small in a text editor, change the section for innodb to look like this:

 

# Uncomment the following if you are NOT using innodb tables

#skip-innodb

 

# Uncomment the following if you are using Innobase tables

innodb_data_file_path = ibdata1:100M

innodb_data_home_dir = /usr/local/mysql/data/

innodb_log_group_home_dir = /usr/local/mysql/data/

innodb_log_arch_dir = /usr/local/mysql/data/

set-variable = innodb_mirrored_log_groups=1

set-variable = innodb_log_files_in_group=3

set-variable = innodb_log_file_size=5M

set-variable = innodb_log_buffer_size=8M

innodb_flush_log_at_trx_commit=1

innodb_log_archive=0

set-variable = innodb_buffer_pool_size=16M

set-variable = innodb_additional_mem_pool_size=2M

set-variable = innodb_file_io_threads=4

set-variable = innodb_lock_wait_timeout=50

 

Re-start the servers, run phpMyAdmin, click on databases, click on the Engines tab and you should see InnoDB listed click on it, look for Buffer pool size 16,384 KiB, this confirms it is enabled (Uniform Server value) Note: If you still see "InnoDB has been disabled for this MySQL server." ignore it.

 

While still in phpMyAdmin click databases, in the Create new database text box type gallery2 and click create. (Assumes you have not already done this), Now have another go at installing gallery2.

 

2). Is there a way to use gallery2 with MyISAM?

 

If that fails you can always use MyISAM database engine.

At step 5 of the gallery2 install wizard, from the select database drop down menu select MySQL version before v.3.23.34a .

 

All the best

Ric :P

Share this post


Link to post
Share on other sites

Note: Upgrade to 4.2-Mona

You only need to edit a single line in the following file:

 

UniServer\udrive\usr\local\mysql\my.cnf (or just “my” if the “.cnf” is hidden!)

 

Locate this section:

# Note: The innodb block is enabled/disabled using a single line

# Uncomment the next line to disable innodb tables. Comment line to enable innodb tables

 

skip-innodb

 

Change to:

Locate this section:

# Note: The innodb block is enabled/disabled using a single line

# Uncomment the next line to disable innodb tables. Comment line to enable innodb tables

 

#skip-innodb

 

Restart the servers.

 

All the best

Ric :blink:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...