Jump to content
The Uniform Server Community
DannyH

question about virtualhost

Recommended Posts

I have a question about virtual host,

 

 

All virtual hosting is working correctly and pointing to the correct folder, but I just don't understand why, if I type the URL into my browser without WWW it will always default to the first virtual host WWW.MYSITE-1 :D

 

I have 3 folders in \www

 

mysite1

 

mysite2

 

mysite3

 

 

 

##########VIRTUAL HOST SETUP##########

# WWW.MY-SITE-1

<VirtualHost *>

ServerName www.my-site-1

DocumentRoot /www/mysite1

</VirtualHost>

 

##########VIRTUAL HOST SETUP##########

# WWW.MY-SITE-2

<VirtualHost *>

ServerName www.my-site-2

DocumentRoot /www/mysite2

</VirtualHost>

 

##########VIRTUAL HOST SETUP##########

# WWW.MY-SITE-3

<VirtualHost *>

ServerName www.my-site-3

DocumentRoot /www/mysite3

</VirtualHost>

 

 

 

Am I missing something here, have read through the Forums but can’t seem to find anyone with the same problem?

 

 

DannyH :D


Personal website

 

Uniform Server - hMail Server - Joomla

Share this post


Link to post
Share on other sites

Hi Olajide

Today I finally got me links sorted and promise not to keep changing them, sent you a PM. :D

 

For virtual hosts these pages may help:

 

http://center.uniformserver.com/u35_mod_ss...ulti_sites.html

http://center.uniformserver.com/virtual_ho...ual_host_1.html

http://center.uniformserver.com/virtual_ho...host_pac_4.html

 

All the best

Ric :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...