Jump to content
The Uniform Server Community
Kaser

Pages not showing up

Recommended Posts

I downloaded uniformserver3_5.exe and installed it to C:/uniformserver/

 

I have used this software for the last couple years and just now had to get a new computer... and it's not working.

 

I run Disk_Start and it starts, takes me to the uniform page, then redirects me to what's supposed to be the admin panel, but it's just a plain white page.

 

none of the files that are in my www folder all show up the same way too, just a blank white page.

 

thanks for the help.

Share this post


Link to post
Share on other sites

Yes, I am useing windows xp. What is IIS? How do I know if it is on or not.

 

I do not have any other servers running, that I'm aware of.

Share this post


Link to post
Share on other sites

Go to teh Uninstall Programs, if you see it there... Also, does it give you an error? or not? when you start the server.

It is not in the uninstall list.

 

No errors... Just a blank page. PHPMyAdmin, my files.. the files that came with uniform server... Everything. Just a blank page.

 

Doesn't give me a 404 or cannot connect though.

Share this post


Link to post
Share on other sites

i also just did another fresh install and it's still not doing anything... :-/

Share this post


Link to post
Share on other sites

Do you know the process name? I don't see anything about IIS in the process list...

 

BTW...

 

I installed uniform server 2 days ago, and the first day it worked fine. The second day it stopped working, and hasn't worked since then. Should I restart computer, maybe?

Share this post


Link to post
Share on other sites

Yeah, umm, try that? lol.

Didn't work.

 

What am I supposed to be running first? After I restart, if I run unicontroller, i put disk W, and click yes to start mysql server.. then nothing happens.

 

if I run disk_start.vbscript, put in disk w... pops up redirect html... but then /apanel/ is just blank.

if I run server_start.batch it just says disk w is busy, or it does nothing

Share this post


Link to post
Share on other sites

allright so I went into my msconfig and disabled everything at startup...

 

restarted, then ran server_start.batch and it works fine.

 

weird.. but it's fixed...

Share this post


Link to post
Share on other sites

Just had the same problem (a blank apanel page), after a couple of hours googling for answers, i started ending processes. After some trial and error i found the offending piece of software, in my case it was EVEMON, chances are that it's an application that starts at startup.

Share this post


Link to post
Share on other sites

Hi,

I was just wondering has anyone used my Perl Script tester! :D

 

http://center.uniformserver.com/us_35/us35...s_3.html#tester

 

All the best

Ric :)

I've just tried the tester and it comes back with

The NTVDM has encountered an illegal instruction

CS:0f6b IP:0260 OP:fe 2e f6 ad Choose 'Close' to terminate the application :D

 

 

I have a similar problem to first poster and I've followed the steps.

 

Version 3.5

 

After clicking server_start.bat, drive W: gets created, apache fires up, firefox goes to "file:///W:/home/admin/www/redirect.html" and tries to load up but gets stuck with the logo.

 

Turned off skype.

IIS not installed.

Disabled firewall and antivirus

MSconfig, disable other start up items

Tried using uc_check but it didn't work on my PC

Manually checked for php.ini and libmysql.dll in PATHS

Did netstat and checked for 80, only process was 0.0.0.0:80 which turned out to be apache.

 

Apache runs taking up 100% of cpu but firefox is unable to load http://localhost/apanel.

 

Using taskinfo, it shows two apache process, one idle and one 100%.

 

Any suggestions?

 

Many thanks

Alan

Share this post


Link to post
Share on other sites

Um.. The tester script should run, would have accepted a challenge you do not have admin privileges to run this script. :)

 

However what concerns me is that message “NTVDM has encountered an illegal instruction” seems as if there is a whole host of reasons for that, virus and malware were a few I found after doing a quick search on the Internet. :D

 

For whatever reasons it looks like you are unable to run Perl (may explain why it gets stuck with the logo.)

 

You can test Perl independent of UniServer have a look at this page:

 

http://center.uniformserver.com/new_users_...ers_perl_2.html

 

As for the two instances of Apache quite normal one is a background task and the other the main server (not hundred percent sure on that). Now 100% CPU time, when to all intense and purpose it is not doing anything is abnormal.

 

Stop the servers, check the log files in *\Uniform Server\udrive\usr\local\apache2\logs

Files: error.log and access.log

If the files are large open in a text editor delete content and re-save.

Re-start your servers, wait a short time and then stop them.

 

At most they will now have about ten lines each. Just wondering does this shed any light on the problem.

 

I am still concerned about this “NTVDM has encountered an illegal instruction” :D

 

It’s not a solution, but at least points you in the right direction!

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Hi,

Um.. The tester script should run, would have accepted a challenge you do not have admin privileges to run this script. :)

 

However what concerns me is that message “NTVDM has encountered an illegal instruction” seems as if there is a whole host of reasons for that, virus and malware were a few I found after doing a quick search on the Internet. :D

 

For whatever reasons it looks like you are unable to run Perl (may explain why it gets stuck with the logo.)

 

You can test Perl independent of UniServer have a look at this page:

 

http://center.uniformserver.com/new_users_...ers_perl_2.html

 

As for the two instances of Apache quite normal one is a background task and the other the main server (not hundred percent sure on that). Now 100% CPU time, when to all intense and purpose it is not doing anything is abnormal.

 

Stop the servers, check the log files in *\Uniform Server\udrive\usr\local\apache2\logs

Files: error.log and access.log

If the files are large open in a text editor delete content and re-save.

Re-start your servers, wait a short time and then stop them.

 

At most they will now have about ten lines each. Just wondering does this shed any light on the problem.

 

I am still concerned about this “NTVDM has encountered an illegal instruction” :D

 

It’s not a solution, but at least points you in the right direction!

 

All the best

Ric :)

Thanks for your suggestions.

 

access.log was empty

error.log has this

 

[Tue Nov 06 22:08:06 2007] [notice] Apache/2.0.59 (Win32) DAV/2 PHP/5.2.3 configured -- resuming normal operations

[Tue Nov 06 22:08:06 2007] [notice] Server built: Jul 27 2006 15:55:03

[Tue Nov 06 22:08:06 2007] [notice] Parent: Created child process 5244

[Tue Nov 06 22:08:06 2007] [notice] Child 5244: Child process is running

[Tue Nov 06 22:08:06 2007] [notice] Child 5244: Acquired the start mutex.

[Tue Nov 06 22:08:06 2007] [notice] Child 5244: Starting 250 worker threads.

[Tue Nov 06 22:08:07 2007] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 5244: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

[Tue Nov 06 22:08:07 2007] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 5244: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

 

No firewall running.

No VPN running.

I searched for "dynamic address renewal" and came across people having problems with antivirus software.

I'm using comodo anitvirus - checked the website and found this

http://forums.comodo.com/help_for_comodo_a...g31636#msg31636

"This is easy enough to fix:

 

Put the Win32DisableAcceptEx directive in your httpd.conf

 

This will force apache to use accept() instead of the non-standard, ms exclusive acceptEx()--which creates the conflict with CAV and others.

 

The difference? MS rolled a lot of the preliminary connection activities into one step. This is good if you do many sessions at once, but most folks that are using Apache on Windows are not in production, so you see no difference. We have a large production web service (we run that on 64bit NSA Linux), but profiling the windows port (which we use for development) shows that we spend very little time (less than a fraction of 1%) in connection, compared to the rest. So it seems a good tradeoff for AV protection.

 

I am not sure why one would be uncomfortable in moving away from a non-standard, MS only acceptEX() (it is not in WinSock spec) to an interface that is a standard...but that is for them to decide.

 

Here are the references:

 

MSDN: http://msdn2.microsoft.com/en-US/library/ms737524.aspx

Apache: http://httpd.apache.org/docs/2.0/mod/mpm_winnt.html

 

Good luck all..."

 

So as you guys are the experts in userve, any problems with "Win32DisableAcceptEx" in httpd.conf?

... and where would be a good place to put it?

 

Many thanks

Alan

Share this post


Link to post
Share on other sites

Hi Alan thanks for the feedback and your solution with write-up.

I am no an expert hence the alarm bells when I saw that error message “NTVDM has encountered an illegal instruction”

 

This type of problem is a real pain to track down, you have done a lot of legwork in finding a solution, thanks for the post, I am sure it will help others.

All the best

Ric :D

Share this post


Link to post
Share on other sites

Hi Ric,

Hi Alan thanks for the feedback and your solution with write-up.

I am no an expert hence the alarm bells when I saw that error message “NTVDM has encountered an illegal instruction”

 

This type of problem is a real pain to track down, you have done a lot of legwork in finding a solution, thanks for the post, I am sure it will help others.

All the best

Ric :D

Just to follow up, I added "Win32DisableAcceptEx" to the end of the httpd.conf file and everything works fine :D

 

I'm also running

Comodo Antivirus CAV

Comodo Personal Firewall CPF

Skype / Tools / Options / Advanced / Connections / untick use port 80 & 443

msconfig is back to normal,

and everything works fine :)

 

Regards

Alan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...