Jump to content
The Uniform Server Community
dennooze

Need help simulating Apache

Recommended Posts

Recently, I was asked by my company to setup OpenBravoERP. But bad thing is, it requires Apache TOMCAT and Apache ANT. Which I can't find them in Uniform Server. I tried to download their binary files and put them into uniform server. But I just can't seem to get it running even when I double click the run.bat files.

 

Is there anyway I can fix this problem ? Coz the Openbravo ERP installation is quite complex and I really need assistance in installing them. The documentation given by OpenBravoERP is very brief and it just teaches you to do environmental variable settings in Windows OS and also the setup of the software.

 

I tried installing them together with the Oracle database (running at port 8080). And the Apache TOMCAT I pointed it to port 80. Again I tried installing the Windows version Apache TOMCAT. This one works well, but the Apache ANT, it only comes in binary files which doesn't include installers. It makes it hard for me to get it running.

 

The OpenBravo ERP is always starting up and pointing to address

http://localhost/openbravo

 

By default the installation of OpenBravo ERP is @ c:\OpenBravoERP. I even tried installing it directly into the uniformserver www folder. Still the address is pointing there. As far as I know the default address of Uniformserver ends with apanel which looks like this :-

 

The actual installation is installed in folder name http://localhost/apanel/openbravoerp

 

The OpenBravo ERP webby is @

http://www.openbravo.com

Requirements : Oracle XE database, Apache TOMCAT, Apache ANT

Please refer to the WIKI under quick-installation guide.

 

I only requires better guide for me to install the OpenBravo ERP. The installation guide provided is not sufficient to help me complete my task. I'm not so sure what the Apache Ant and TOMCAT does, i'm really in desperate situation to get it up running. I totally have no knowledge in setting up such server, all I can do is giving appropriate information and ask you guys to assist me.

Share this post


Link to post
Share on other sites

Ummm i have never used Apache ANT before but some mistakes i've seen from you so far is that you think the start link starts at http://localhost/ apanel/.... but it doesnt. Thats the link to the Admin Panel! Not the main WWW link.

 

The main WWW link is http://localhost/ .... If you have a direcotry in the W:/www folder names Blah, then to enter the Blah directory, go to http://localhost/Blah

 

So if you installed the program under that directory, then that link is right... You said you got Tomcat working, but about Ant i do not know... Never used it.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...