Jump to content
The Uniform Server Community
jafo

memory_limit

Recommended Posts

Having a problem installing a php shopping cart. Getting the error memory_limit needs to be at least 20MB.

Default in Uniform Server is 32M, have set it to others even higher still no go.

Is this a problem with the way Apache was compiled using the RLimitMEM directive?

Is there anyway to change this in https.conf or .htaccess?

 

windows 2000

Uniform Server 3.5

Avactis Shopping cart 1.7.2

 

Thanks!

Share this post


Link to post
Share on other sites

No.. it should work if you set the memory_limit to something greater than 20, like 32M the default. Did you try asking the support team of the software?

Share this post


Link to post
Share on other sites

No.. it should work if you set the memory_limit to something greater than 20, like 32M the default. Did you try asking the support team of the software?

 

Yep, asked Link

 

Really perplexed over this. I have tried everything I can think of.

Share this post


Link to post
Share on other sites

The memory limit of 30M is more than adequate. There is nothing in the settings relating to 15M. However there is one element that changes memory, eAccelerator.

 

Before attempting an installation disable this accelerator.

 

1) Go into apanel

2) Click on eAccelerator cPanel (left menu, just under Plugin Manger)

3) This will bring up a control panel.

4) Under “Actions” you will find five buttons:

From the bottom up, click on purge, clean and then clear.

5) Finally click the top two buttons so they display enable

 

The above will disable the accelerator until you either re-start the servers or you click on the two enable buttons.

 

Anyway with the accelerator disabled try installing again and see what memory is reported.

 

It’s a long shot but I can’t see what else would cause this problem. :)

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

The memory limit of 30M is more than adequate. There is nothing in the settings relating to 15M. However there is one element that changes memory, eAccelerator.

 

Before attempting an installation disable this accelerator.

 

1) Go into apanel

2) Click on eAccelerator cPanel (left menu, just under Plugin Manger)

3) This will bring up a control panel.

4) Under “Actions” you will find five buttons:

From the bottom up, click on purge, clean and then clear.

5) Finally click the top two buttons so they display enable

 

The above will disable the accelerator until you either re-start the servers or you click on the two enable buttons.

 

Anyway with the accelerator disabled try installing again and see what memory is reported.

 

It’s a long shot but I can’t see what else would cause this problem. :)

 

All the best

Ric :)

 

That was exactly it. I think eAccelorator was the main problem or the cashe.

 

Would have gotten back to you sooner but your server was down... which makes me scratch my head lol.

Share this post


Link to post
Share on other sites

Thanks for the feed back, excellent news. :blink:

Would have gotten back to you sooner but your server was down... which makes me scratch my head lol.

No need to scratch your head, servers do that sometimes (crash or whatever) welcome to the real world. :)

I could not get through, though Olajide had black listed me :) .

All the best

Ric :huh:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...