Jump to content
The Uniform Server Community
Christian

Can't Access Server

Recommended Posts

I have looked through the forums for this question, but have only found bits and pieces, never a straight-forward answer to my issue.

 

My background with servers is extremely limited. I don't work with server, I only do web administration. Apache is a very complex, foreign tool for me. However, with my new job, I need a personal, home server in order to show my clients my web projects that I'm working on. This will be VERY light traffic to the server.

 

That being said... I just installed Uniform Server on my PC, running Windowx XP. My computer is connected to the internet through a wireless connection to my router (a Linksys WRT54G Wireless - G Broadband Router), which is connected to my cable modem.

 

I can access 127.0.0.1/localhost fine on my local PC. What I cannot do is access the server from another computer. I've read something about port forwarding, but I really am not sure where to even start with this. I didn't see any port forwarding features in my Wireless Modem administrative panel.

 

Has anyone successfully been able to access the Uniform Server from a wireless connection? If so, what steps did you take? Is there easy-to-read/understand documentation on this?

 

I am also registered with DynDNS.com, but again, I'm not too sure where to start. :lol:

 

Thanks for any and all help you guys can provide!

 

Christian

Share this post


Link to post
Share on other sites

For the DYNDNS Settup, someone wrote a nice little tutorial in the main Support Forum. Check it out. Its Pinned.

 

About the other problem, A, what you have to do is go to the /www/ folder, edit the .htaccess file with Notepad and comment the line where it state you should to open the server.

 

After that, on your modem you have to forward all calls from port 80 to the machine with Uniform Server on there....

 

On your linksys router admin, go to Application & Gaming, under it you should see Port Rage Forward, Application: Web, Start: 80, End: 80, IP: (IP of the computer you have Uniform Server on) and click Enable, and you should be able to access it outside your network now....

Share this post


Link to post
Share on other sites

Thank you so much for your response! I changed those settings on my router, and I was able to access the server from my MAC. Thanks!

 

Now, I'll check out the DynDNS set up documentation.

 

Thanks again,

 

Christian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...