Jump to content
The Uniform Server Community
Sign in to follow this  
Phaeton

Login page error

Recommended Posts

Hi i just followed this tutorial on creating a login page in dreamweaver mx with php and mysql. http://www.adesdesign.net/php/tutorials/dr...ecure_login.php

This tutorial is fairly straight forward and i think there's nothing wrong with it.

 

I followed the given steps and when i was done and tried to reach the login page, i got this error.

 

Warning: main(Connections/connectDB.php) [function.main]: failed to open stream: No such file or directory in W:\www\login.php on line 1

 

Fatal error: main() [function.require]: Failed opening required 'Connections/connectDB.php' (include_path='.;/usr/local/PHP/includes;/usr/local/PHP/pear') in W:\www\login.php on line 1

 

I think it has something to do with uniform server but i don't know what.

 

Can somebody help me fix this problem.

 

Thanks in advance

Share this post


Link to post
Share on other sites

A. You post was moved to the right forum.

B. It is not a problem with Uniform Server or anyhting of such, but what you have installed.

C. You have to install Pear on your server.

D. To install first get the updated version of go_pear.php at http://go-pear.org/

E. Save that to "W:/home/admin/www/plugins/pear/" and then run it.. It will automatically install Pear for you.

F. You are done :D

Share this post


Link to post
Share on other sites

I followed you tips but i'm unable to complete the installation.

I get this error:

The requested URL /co.php/pear-core/PEAR.php was not found on this server.

Share this post


Link to post
Share on other sites

You must have done something wrong.

 

Did you replace the go_pear.php file with the one you got from the go-pear.org site?

 

If this still does not work go to pear.php.net and download the package itself.

Share this post


Link to post
Share on other sites

(My initial pear file was named Uni_go-pear.php)

 

I took the go-pear.php file and placed in in my websire root.

Then i accessed itfrom my browser.Changed the installation prefix to W:\home\admin\WWW\plugins and the php.exe file path to W:\usr\local\Php

Not changing the installation prefix doesn't make any difference.

Share this post


Link to post
Share on other sites

Do not change anything at all. After you download it just run it and click next and it should work. You do not need to set anything or do anything. Just lick start or run or whatever it says.. maybe next :D

Share this post


Link to post
Share on other sites

As I stated in my previous post, if I leave the settings as they are, the error stil shows up.

I downloaded the PEAR package but i have no clue what to do with it.

I tried to run a few of the php files but they all turn up with the same errors.

And the bat files in the package don't do anyhting.

 

I need some serious help here, i can't create a thing without this PEAR.

Got some more tips / suggestions ??

Share this post


Link to post
Share on other sites

lol.. u make me laugh.. :D

 

Here is what you need, you need the PEAR.php file, and the Connections folder.

 

Copy the PEAR.php file and the whole Connections folder with connectDB.php in it to where your script is located.

 

It should work. That is the best way to do it....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...