Jump to content
The Uniform Server Community

BenNedge

Member
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About BenNedge

  • Rank
    Newbie

Previous Fields

  • Main OS
    Windows 10
  1. FIXED ! I was using the wrong extensions extension=php_sqlsrv_74_nts_x64.dll extension=php_pdo_sqlsrv_74_nts_x64.dll extension=php_sqlsrv_74_nts_x86.dll extension=php_pdo_sqlsrv_74_nts_x86.dll needed to be: extension=php_sqlsrv_74_ts_x64.dll extension=php_pdo_sqlsrv_74_ts_x64.dll extension=php_sqlsrv_74_ts_x86.dll extension=php_pdo_sqlsrv_74_ts_x86.dll thank you to anyone who viewed this post.
  2. Good Morning Uni Server Users, I have UniServer Zero XIV running with PHP 7.4.0 I can connect fine to MySql databases, But I can not connect to MSSQL using sqlsrv_connect(). I have downloaded and added the following extensions to the extensions folder and the production.ini. extension=php_sqlsrv_74_nts_x64.dll extension=php_pdo_sqlsrv_74_nts_x64.dll extension=php_sqlsrv_74_nts_x86.dll extension=php_pdo_sqlsrv_74_nts_x86.dll I can see them when I go into the select active module list on the uni controller PHP >> Edit Basic Modules >> PHP Modules Enable/Disable However when I check the PHPinfo() they are not listed under extensions. I checked the logs to see what error is and im getting an unable to load error. The files location for these files are: C:\UniServerZ\core\php74\extensions I notice there is a double slash in the location that apache is looking for this extension, if this causing the issue and stopping the extension from loading. How do I change this if this is what is causing the issue? If you need any more information please let me know. I must be doing something wrong with the extensions but I'm just not sure what. Kind regards, and many thanks Ben
×
×
  • Create New...