Jump to content
The Uniform Server Community

GoodOlJoe

Member
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About GoodOlJoe

  • Rank
    Junior Member

Previous Fields

  • Main OS
    Windows 7
  1. GoodOlJoe

    PC Win Start-up

    You can do it with batch files. Just change the drives and folders to suit your setup. Place something like this in your startup folder for Windows 10 just hit the windows key + R and type SHELL:STARTUP and it will run when you start up the computer. You can also place it on your desktop ---------------- BEGIN SCRIPTS ------------------- CLS echo off rem elevate to run the script if not "%1"=="am_admin" (powershell start -verb runas '%0' am_admin & exit /b) :START_UNICONTROLLER rem add a small timeout TIMEOUT /T 1 >nul rem start up both servers - UniController and MySQL C:\Windows\System32\cmd.exe /c c:\UniServerZ\UniController.exe start_both exit To shutdown the servers c:\Windows\System32\cmd.exe /c tasklist /fi "IMAGENAME eq httpd_z.exe" 2>NUL | find /I /N "httpd_z.exe">NUL if "%ERRORLEVEL%"=="0" ( c:\Windows\System32\cmd.exe /c c:\UniServerZ\UniController.exe stop_both ) ) else ( if "%ERRORLEVEL%"=="0" ( rem MySqld_z.exe is not running ) goto another_task ) To shutdown the controller :KILL_UNICONTROLLER c:\Windows\System32\cmd.exe /c tasklist /fi "IMAGENAME eq UniController.exe" 2>NUL | find /I /N "UniController.exe">NUL if "%ERRORLEVEL%"=="0" ( c:\Windows\System32\cmd.exe /c taskkill /F /IM UniController.exe )
  2. This error occures when you run UniController from a folder other than the one it was installed in such as a temporary backup location. Be sure you are running the controller.exe from it's root (like C:/UniServerZ) and not something else.
  3. I would delete this post if the option still existed but it no longer does. Basically I found another way to accomplish this task but thanks for allowing me to post it anyway. Joe
  4. I'm on a Windows 7 box and as an exercise, I am attempting to migrate a live test site from VI to V4 because I would like to be able to do this with my real site in order to be able to easily update PHP.. I have more than one version on on my drive I and need to switch back and forth to make changes in each versions Wordpress control panel to the plugins etc set up. I do this by running one and then renaming the folders (one to UniServerZ_back and the other back to UniServerZ) while doing the prep. Before installing Version 4 I had no trouble doing this but after installing V4 there seems to now be a problem in that when I rename the folders and run the opposite Version of UniController. I'll get a pop-up error stating " Incorrect location! Move UniController to folder UniServerZ"... To prevent problems UniController will close. But UniController (and all the other files) are in fact installed in the correct C:/UniServerZ folder before I run UniController. I have tried to correct this and or work around it by reinstalling a fresh copy and then copying my current files into that fresh install but the problem persists. Would appreciate any help please. Might there be a cfg file setting that might be pointing to a different folder even though UniController is actually in the correct folder? Joe
  5. Ok I found the problem was apparently my browsers needed the cache's flushed. The program is presently running and I am external and locally able to communicate through it. Thanks for everything. Joe
  6. I thought I had it licked. Not sure what happened but I'm getting a sever rejected connection message. I've reinstalled it several times, don't think I'm missing anything but no luck. I'm going to have to give up unless you can give me some advice. I can get localhost fine but no remote and yes the hosts file does not have a redirect in it. The htaccess files are # out, I just don't understand what is going wrong, it all looks so simple.
  7. I see. If I change the local url to "localhost:81" then I connect locally. mydomain.com connects remotely from any computer including the local one.
  8. Thank you for your help Ric, I didn't realize that when I changed the Apache config port the program automatically set a line in the hosts file so I deleted the line and it now does allow me to see the page externally. The basic steps I took are these: 1) Edit Basic Configuration Server name = "mydomain.com" also add Server Admin Email (Change Listen port set to 81) 2) Extra Edit Win Hosts File Delete the Hosts entry for myDomain.com 3) Access and Passwords Password Disabled (for now) Set to "Local, Intranet and Internet Access" >>> start Apache Server <<< Local page FAILS to resolve Try URL from a separate remote system (no :81 in url) (SUCCESS! system connects remotely :D ) Try URL again from local system but remove the :81 from the URL SUCCESS! (system connects locally :D but :81 had to be removed) ----------------------------------------------------------------------------------------------------- Bottom line... and just to be clear, when I stop and restart Apache, on start it automatically brings up (or tries to bring up) the page locally and fails with port 81 automatically attached to the local url UNLESS I remove the :81 from the local (mydomain.com) URL and try again it resolves just fine (I assume) because it is doing so over the internet though my noip redirect just like any external system would. This means I can not connect locally unless I change my ip back to 80 for that moment to do so. I don't think this is a bad thing because I could certainly work around it but I just want to be clear about it. Do I have this correct? Thank you very much for your courtious help. Joe P.S. donation coming
  9. I've looked this over pretty well and I'm fairly sure when you change the apache listen port it should not be appended to the URL above. This has to be an overlooked bug because it makes it pretty much impossible to use a registered domain name that has a port redirect on it unless I've missed some setting somewhere.
  10. Currently I run a production server on xampp with no real problems. I ran into a thread that mentioned your software so I wanted to see if I could use it as a usb alternative. That said, I am having difficulty getting uzoro to connect my site to the wan. My Setup: I have a fqdn and a port 81 noip redirect with noip. In Basic Apache Config (BAC) I have added my registered domain name to Server name. I have also installed wordpress into the www folder, created the database and WP install. This allows me to login as www.mydomain-name.com through localhost. I need to connect through port 81 so I change the listen port in BAC to 81 and when I do this I lose connection with the site altogether. It appears that when I change the Apache listen port to 81, I see that uzoro appends the port# :81 to the url and it looks like this: www.my-domain.com:81 Now since my url already has a port 81 redirect silently added by noip I believe this causes the dns to see this as www.my-domain.com:81:81 I'm not having any luck finding what I'm doing wrong with this setup. Can someone give me a little guidence as to what I am missing or doing wrong here? Thanks for any assistance, Joe
  11. it would be very nice of someone could update this post to reflect todays needs of uzoro.
×
×
  • Create New...