Jump to content
The Uniform Server Community

grabby

Member
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About grabby

  • Rank
    Newbie

Previous Fields

  • Main OS
    Windows XP
  1. grabby

    Crash with 8.3.1

    I recently upgraded from Coral 8.0.0 to Coral 8.3.1 on my local Vista machine to better reflect the configuration of my live server. Most of my vhosts run ok, but when I import a database with one and try to view it I get “PHP Script Interpreter has stopped working properly” Product Apache HTTP Server Problem Stopped working Date 2013/02/15 03:25 PM Status More information available Problem signature Problem Event Name: APPCRASH Application Name: httpd1.exe Application Version: 2.4.1.0 Application Timestamp: 4f3aa5c8 Fault Module Name: php5ts.dll Fault Module Version: 5.3.10.0 Fault Module Timestamp: 4f2ae5d1 Exception Code: c0000005 Exception Offset: 000a3b02 OS Version: 6.0.6002.2.2.0.768.3 Locale ID: 7177 Additional Information 1: fd00 Additional Information 2: ea6f5fe8924aaa756324d57f87834160 Additional Information 3: fd00 Additional Information 4: ea6f5fe8924aaa756324d57f87834160 I really don’t know where to start getting a handle on this. I’m running UniServer as a program.
  2. Hi Yoni, Thanks for the quick reply. I don’t think it’s a path issue because my other sites all work fine, it’s only the one with the ssl that causes this. To make sure I put everything back in C:\UniServer\vhosts\mysite1 C:\UniServer\vhosts\mysite2 etc. and adjusted everything accordingly, but the problem didn’t go away!
  3. After I got a number of dev sites up including one with an ssl cert with Coral 8.0.0 as per Yoni’s advice in http://forum.uniformserver.com/index.php?showtopic=2467 I decided to upgrade to 8.1.1. Everything was fine until I went to the site with the certificate, which caused Apache to crash with the message Apache HTTP Server has encountered a problem and needs to close. We are sorry for the inconvenience. Of course I had generated a new certificate in 8.1.1. The content of the error message started with AppName: httpd1.exe AppVer: 2.2.22.0 ModName: php5ts.dll ModVer: 5.3.10.0 Offset: 000a3b02 Clicking on “more information” after reporting the error took me to http://wer.microsoft.com/responses/Respons...b9-4d3b4c938009 which states PHP Script Interpreter has stopped working properly. Meanwhile, the Apache syntax checks OK. The only other difference from my 8.0.0 installation is that instead of leaving UniServer in its directory so that my sites ended up in, say C:\UniServer\vhosts\mysite1 C:\UniServer\vhosts\mysite2 etc. I put it straight into the top of the drive since I don’t have anything else there, so the sites end up in C:\vhosts\mysite1 C:\vhosts\mysite2 etc. Any idea what’s going on?
  4. After I boot into XP I can start Coral without a hitch, everything’s fine. If I stop the servers AND exit the program, however, I can’t restart the program without rebooting. I’ve only been using Coral for a couple weeks, so I don’t know if this has been going on from the start, or if it’s something that cropped up along the way. It’s annoying because I use my computer for a variety of things and find myself switching from using Coral, to not using it, to using it etc. There are no sql or httpd processes to kill either, since they’re gone after I stop the program. I’ve never run it as a service. Any ideas as to what might be causing this?
  5. grabby

    ssl configuration

    Hi Yoni, Bob’s right, it sure helped a lot, everything’s working perfectly! Now I’m going to get greedy and try to set up another partially secure site in the same installation, but I don’t see why it shouldn’t work, at least in this dev setup I’m working in. Thanks again!
  6. grabby

    ssl configuration

    Hi Bob, Thanks for the reply. I’m running Coral 8.0.0. There’s no problem with the hosts file, as it has 127.0.0.1 mysite.com listed. If this hadn’t been there I don’t think the non-secure part of the site would have worked. The end of my httpd.conf looks like this ##====== VIRTUAL HOST =========== #To enable uncomment next line Include conf/extra/httpd-vhosts.conf ### Section 4: Secure section # Secure (SSL/TLS) connections # Include conf/ssl.conf # # Note: The following must must be present to support # starting without SSL on platforms with no /dev/random equivalent # but a statically compiled-in mod_ssl. # #<IfModule ssl_module> # SSLRandomSeed startup builtin # SSLRandomSeed connect builtin #</IfModule> # Distributed authoring and versioning (WebDAV) #Include conf/extra/httpd-dav.conf <IfModule mod_ssl.c> Include conf/extra/ssl.conf </IfModule> My httpd-vhosts is as follows: <VirtualHost _default_:80> DocumentRoot D:/UniServer/www ServerName localhost ErrorLog "logs/error.log" CustomLog "logs/access.log" common </VirtualHost> <VirtualHost *:80> ServerAdmin webmaster@mysite.com DocumentRoot D:/UniServer/www/mysite ServerName mysite.com ServerAlias www.mysite.com *.mysite.com ErrorLog logs/mysite.com-error.log CustomLog logs/mysite.com-access.log common </VirtualHost> Another thing I don’t understand exactly is that when I go to https://mysite.com/ I get the UniServer index page in the www directory whereas when I go to http://mysite.com/ I get my site’s front page, which isn’t secure. Thanks for helping to investigate this!
  7. grabby

    ssl configuration

    I’m trying to set up a local test environment on XP for a site that was in production on a linux server. It’s an ecommerce site using Drupal and its Secure Pages module, which allowed certain pages to redirect to https versions. I installed the site in www/mysite by creating a virtual host for mysite.com and generated a certificate. The non-secure part of the site works fine, but the secure pages aren’t getting served (404). I modified ssl.conf to point to the www directory since that’s where the site is located, but this didn’t help. I also tried putting the whole site in the ssl directory, but nothing changed – the non-secure part worked and the secure part wasn’t served. When I click “View ssl” it gives me the index page for www, or ssl when I tried it there. I’m stuck and would appreciate any help with this!
×
×
  • Create New...