Jump to content
The Uniform Server Community

bincho

Member
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About bincho

  • Rank
    Newbie
  1. I recently got UniServer configured as a public server with dynamic DNS redirection to an alternate port with the help of AlleyKat. My computer is connected directly to the internet but my ISP happens to block port 80. After tweaking some files and getting it working perfectly, I decided it was time to post the information. Two assumptions will be made here. One: the computer this is being configured on has an internet IP address, which means you are not behind a NAT/router. Two: You've got UniServer unpacked and are ready to go. The first step is to actually make Apache listen on the alternate port. I used port 81, and that seems to be the typical alternative. To change this, edit the http.conf file located in diskw\usr\local\Apache2\conf. There are two lines that need to be changed in the default file. Listen 80 Change it to: Listen 81 The other line is: ServerName localhost:80 Which should be changed to: ServerName localhost:81 After these changes have been made the Apache server will now allow connections on port 81. The next step is to allow outsiders to view the home directory and all subdirectories, because right now they are forbidden from doing so. Go to diskw\www and open .htaccess, then comment out the following three lines: Order Deny,Allow Deny from all Allow from 127.0.0.1 Like so: #Order Deny,Allow #Deny from all #Allow from 127.0.0.1 The only directory(s) this change affects is the one it resides in and any subdirectories. Now you can start your server and it will function, but there are still a few problems to work out. If you load the administrator page, and it actually works, then anything you attempt to change that affects the server will probably not work. This is because the administrator page doesn't know to check port 81. To fix this we have to change the redirect page that is loaded when the server starts. If you manually navigated to http://localhost:81/a/ then you probably wouldn't have this problem, but the default page still needs to be fixed. The redirect page that needs to be altered is located in diskw\home\admin\WWW, so navigate there and open redirect.html. The redirect.html in the base UniServer folder is not used by start.bat, at least not in version 3.2. There are two lines that should be changed here, and they are as follows: window.location = 'http://localhost/a/'; To: window.location = 'http://localhost:81/a/'; And: <center><a href="http://localhost/a/">Go to main page</a></center> To: <center><a href="http://localhost:81/a/">Go to main page</a></center> After that the default administrator page should work just fine. There is one last thing to fix, though. If you tried to shutdown the server from the admin page you would be rejected due to a small script that checks to make sure the address requesting the shutdown is a local one. I don't believe that completely removing the check would be a good idea, so let's change the offending line of code to check for the new address. Navigate to diskw\home\admin\CGI and open secure.pm, then change the following part of the long line: http[s]?:\/\/localhost\/a/ To: http[s]?:\/\/localhost:81\/a/ Unless I forgot something that just about sums it up. Oh, and if you want free dynamic DNS redirection to a specific IP address, the WebHop option from DynDNS.com offers the functionality required to redirect to a specific address. Just checked phpMyAdmin and that was broke as well, but it has an easy fix. Navigate to diskw\home\admin\WWW\phpMyAdmin-2.6.0-beta2. Open config.inc.php and change the following. $cfg['PmaAbsoluteUri'] = 'http://localhost/a/phpMyAdmin-2.6.0-beta2/'; To: $cfg['PmaAbsoluteUri'] = 'http://localhost:81/a/phpMyAdmin-2.6.0-beta2/';
×
×
  • Create New...