Jump to content
The Uniform Server Community

johntor

Member
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About johntor

  • Rank
    Newbie

Previous Fields

  • Main OS
    Windows Vista
  1. Sorry for the mistake the correct line is: $_SERVER["REQUEST_URI"]=""; the other produces some warnings and is better not to be used. J! PS:always glad to help
  2. I found a quick solution so that I can keep on my job! I inserted the following line: $GLOBALS[_SERVER][REQUEST_URI]=""; into index.php and administrator\index.php Everything works fine! Keep on the good work! J!
  3. A few steps down.... I made this simple script: <?php echo "<pre>"; print_r ($GLOBALS); echo "</pre>"; ?> and I found difference into [_SERVER] and [HTTP_SERVER_VARS] Values into [REQUEST_URI] are different. Using my_hosts.pac into [REQUEST_URI] is the full url while using widows hosts only the script name. Keep on J!
  4. After all this research I made it seems to be a firefox bug. There's must be something sending when requesting from Apache using the pac hosts. Do you think we can get help from firefox team? Thanks once again J!
  5. This is checked on Windows 7 and Windows XP Here is what I did. 1 Extracted UniServer5_6b.exe 2 Ran Server to check it works 3 Installed V56_UniServer_USB_1.0.exe 4 I Create w: letter using subst like the old good days for the uniserver folder 5 Created Virtual joomlatest in folder w:\www\joomlatest (Using Apanel) 6 Created a db with phpmyadmin and I installed latest joomla following the proposed position 7 After installation finished I typed http://joomlatest site appears ok but the home link is http://joomlatesthttp/ 8 edit manually hosts inserting joomlatest 127.0.0.1 9 remove option from firefox using my_hosts.pac (using default windows hosts) 10 Everything is fine. 11 Changing back to using my-hosts.pac 12 Problem is back alternately I go to the administrator panel. (http://testjoomla/administrator/) make an error login then login ok. The url is: http://testjoomlahttp/administrator/index.php and the output window says: Not Found The requested URL /administrator/index.php was not found on this server. Further further more (after hours...) Into my normal firefox installation i changed to use Automatic proxy configuration URL pointing to my_hosts.pac guess what THE SAME! I tried Portable Firefox 3.5.8 no luck! Thank you for your reply J!
  6. I followed the instructions installing on USB. Everything seems ok. The problem is somewhere around the PAC file. I installed joomla into a virtual host the root folder is accessed normally but some links are messed up. for ex. a link http://testjoomla/ is converted to http://testjoomlahttp/ . An http/ is added to the end of the file. If I remove the decleration from pac\my_hosts.pac and insert it into windows hosts file then everything works fine. The problem is at work that I can't modify hosts. I'm not sure if this is a problem of portable firefox. any Ideas suggestions? Thank anyway! J!
×
×
  • Create New...