Jump to content
The Uniform Server Community

jani gracnar

Member
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About jani gracnar

  • Rank
    Junior Member

Previous Fields

  • Main OS
    Windows XP
  1. Problem is solved. The installation of Oracle client was missing so the connection to database could not be established. Thanx, Jani
  2. Hi Ric, The forum was many times down so I am writing now on CA topic. I follow procedure that you post on Aug 19 2009, 03:16 PM, everything is OK. Thanx, Jani
  3. Hi, Can someone help me with connecting UniServer Nano beta2 to Oracle 10g2. I copied php_pdo_oci.dll and php_oci8.dll files into extensions directory end uncomment next 2 lines in all php.ini files: extension=php_oci8.dll extension=php_pdo_oci.dll After stop and then start Apache server the message about missing oci.dll apears. I am running UniServer on one machine and Oracle server on another machine. The oci.dll is on remote machine - comes with Oracle instalation. Is it possible that I have to run both UniServer and Oracle on the same machine? Thanx, Jani
  4. Hi Ric, At the moment I am working on UniServer php pdo sqlite example. Thanx to your post and help I solved this topic. I will try your suggestions about CA during the week so I will post feedback after the week. In near future I am going to use UniServer with Oracle. I will post about my eperience on this topic. Thanx, Jani
  5. Hi, Thank you for your help. Now it works everythink OK. Before your reply I made some mistakes. I changed the order of dlls calling in the ini file and I did not have right version of PHP as source for php_sqlite3.dll and php_pdo_sqlite.dll (now php-5.3.0-Win32-VC6-x86). Thanx, Jani
  6. Hi Ric, Can you help me please to solve my problems with php_pdo_sqlite (with nano beta2). I post a topic on PHP section. I need php_pdo_sqlite working urgent. Thank you for your help, Jani
  7. Hi, I have a problem reading from sqlite 3 database. I use UniServer Nano beta 2. I have copied php_pdo_sqlite.dll file (from original PHP 5.3) to php extensions directory and add line extension=php_pdo_sqlite.dll in php.ini file. When try reading next error message is displayed: could not find driver. Reading with php_pdo_mysql is OK. The PHP code is tested on mini uniform server with php_pdo_sqlite.dll added and php.ini file modification. Thanx for help, Jani
  8. Hi Ric, Can you help me please with CA creation. I have downloaded UniServer_CA plugin and followed instructions from readme.txt file but no success. I replace next files from UniServer_CA/CA: openssl.exe libeay32.dll zlib1.dll ssleay32.dll with files with the same name from apache/bin. Firstly I perform clean.bat and then create_ca.bat. Then I enter company, section and PEM pass phrase which is followed by an error message: 3616:error:0D0AF0AD:asn1 encoding routines:ASN1_TIME_set:error getting time:.\crypto\asn1\a_time.c:109: Thanx, Jani
  9. Hi Ric, Thank you for your help. I made new clean installation of Win XP SP2 on virtual machine. There are 3 msvcrt.dll files on next locations: C:\WINDOWS\system32 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.CPlusPlusRuntime_6595b64144ccf1df_7.0.0.0_x-ww_2726e76a C:\WINDOWS\WinSxS\x86_Microsoft.Windows.CPlusPlusRuntime_6595b64144ccf1df_7.0.2600.5512_x-ww_3fd60d63 I think that maybe last 2 dlls are instaled with VMWare tools, but I cannot confirm this. After that I run UniServer Nano beta2. Localhost OK, than I run Process Explorer and I sow that only msvcrt.dll from C:\WINDOWS\system32 is used. I copied (overwrite) files that you suggested in your previos post and now also https is enabled. Do you think about including this files (needed for https) in next version of UniServer? Maybe it will be usefull to have also Restart command for restarting servers (now Start, Stop)? Thanx, Jani
  10. In addition to my previos post. My previous post refers to UniServer5 beta 2 (latest version). Jani
  11. Hi, Thank you for new version. I make clean installation of Win XP SP2 on virtual machine, unpacked UniServer and runs OK without any additional dlls copying. As you say in your previous post that means higher level of portability. I have another problem. I would like to set up uniform server as https server. If I go to apanel, then server key & cert gen and fill form for domain, company ... next messages are shown: The system cannot execute the spceified program. The system cannot execute the spceified program. Could Not FInd C:\UniServer\unicon\key_cert_gen_gen\server.key Could Not FInd C:\UniServer\unicon\key_cert_gen_gen\server.crt The system cannot find the file specified. If I look in unicon/key_cer_gen there is no server.csr file. There are also missed (not created?) server.crt and server.key files in usr/local/apache2/conf/.... After that I cannot start Apache succesfully. Is maybe some OpenSSL problem? Thanx, Jani
  12. Hi, I make clean installation of WIn XP SP2 on virtual machine. In apache2\bin I removed msvcr71.dll and copied in the same folder msvcr90.dll. But server_start not suceed. Is installation vc++ 2008 redistributable package obligatory? Jani
  13. Hi, I can repeat the clean installation and put msver90.dll in right folder, so I can find out if all thing works without Visual C++ 2008 Redistributable Package. Can you tell me where can I find msver90.dll? Jani
  14. Hi, The solution of my problem was installation of Visual C++ 2008 Redistributable Package (x86). I have done completly new installation of Win XP SP2 so I have missed Visual C++ 2008 Redistributable Package. Now it works fine. Thanx for all your help, Jani
  15. Hi, Port 80 and 443 are not used. I have tried alternative control to start uniform server - after I run start_server.bat from command line next messages were displayed: MySQL port = 3306 - OK to run MySQL server Starting MySQL server ... APache port = 80 - OK to run Apache server SSL not enabled skipping port test. Apache Syntax check - The system cannot execute te specified program. Apache Syntax check - The system cannot execute te specified program. Failed! Please correct Apache config file errors! Cron not enabled in config.inc.php Or disabled by a user parameter Press any key to continue . . . It is very strange because I also cannot start apache from command line with apache -k start (my previos post) .... Thanx, Jani
×
×
  • Create New...