Jump to content
The Uniform Server Community

nv1962

Translator
  • Content Count

    17
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About nv1962

  • Rank
    Translation Team Member

Previous Fields

  • Wiki ID
    nv1962
  • Main OS
    Windows Vista

Contact Methods

  • Website URL
    http://

Profile Information

  • Location
    Reno, NV (USA)
  1. UniServer continues to be amazing. I've just now downloaded the brand spanking new Orion 7.0.1 and it's a breeze setting it up for PHP and MySQL apps. However... I'm trying to dip my toes in the deeper waters of a CGI / Perl type script, i.e. the Movable Type package and that's giving me a headache. Admittedly, it's been a while since I last tinkered with Perl, but I'm getting 500 errors left and right, and just can't get a handle on where to start. So here's a classical newbie question: assuming one has UniServer up and running, and downloaded and installed the "full" Perl package (I used the most current and biggest package to have all modules, i.e. V5.2_full_perl.exe ) and then picked up Movable Type v5 (MT5) and followed the installation steps right through step 5, what else does one need to do to get the MT configuration wizard going? I'm just stuck with stubborn 500 errors, and the UniServer error log shows several lines of this: What am I doing wrong? Just to be clear: I'm not asking for help with MT - that's what the MT documentation is for - instead I'm looking for guidance to get to the point where the installer works. For some reason, calling up the installation script throws out those HTTP 500 errors I showed above, i.e. by going to this direction: http://localhost/cgi-bin/mt/mt.cgi Very strange...
  2. Uh... What's missing is my brain. I was so dumb to pump over an existing server... Yeah. After reinstalling a fresh Mona, I could start just like any standard Basic server. Awesome: a little ultraportable Uniform Server out there with a fully equipped site running on it! Thanks so much for pointing me in the right direction. :-)
  3. Hi, thanks for the Mona-4.0 release! Wrote a little blurb here about it. As usual, an uncanny fast "installation" with great performance. On my desktop it works like a charm. However, I have a very small laptop (an Asus Eee PC 4G running a trimmed XP Home) which doesn't have a harddrive, but solid-state 4GB SRAM instead, so I'm using an SD card as the "external" hard drive. Now, when I fire up UniServer from that SD card, it won't assign a drive letter... I tried the start_bat, the UniController... Nada. Any pointers to get my ultra-portable web server going on the road?
  4. This post cannot be displayed because it is in a password protected forum. Enter Password
  5. This post cannot be displayed because it is in a password protected forum. Enter Password
  6. This post cannot be displayed because it is in a password protected forum. Enter Password
  7. This post cannot be displayed because it is in a password protected forum. Enter Password
  8. This post cannot be displayed because it is in a password protected forum. Enter Password
  9. This post cannot be displayed because it is in a password protected forum. Enter Password
  10. The thing is, I'm not sure which files to pick from the uncompressed files that come in the AS version of ActivePerl, in order to make either CPAN or PPM work (as I understand it, those are the two "recommended" methods to download and install Perl modules that haven't been included in the Uniserver package.) Just to make sure I understood it -- and if so, hopefully it'll be of help to others tracing this issue later as well -- here's what I've done so far: - Went to the Active Perl site: http://www.activeperl.com/ - Downloaded their current Windows version (the AS version, not the MSI version!) of their ActivePerl, after optionally registering. By the way: registering is a good idea because they send you an e-mail with helpful links for further support to install and use Perl! - Uncompressed the .ZIP archive into some folder (since I'm not running Perl "directly" but via Uniserver, and will copy all needed modules / files into the Uniserver folder, the location of the uncompressed ActivePerl files doesn't really matter) - Looked at the available on-line documentation (not in the least, the ample documentation provided here (link) by ActiveState themselves) - Got stumped by the dearth of seemingly related modules and files for either CPAN or PPM... Not knowing which files to pick! Thanks again for your help... PS: I don't have a problem at all with CPAN and/or PPM not being included "out of the box" in the Uniserver package, as Perl comprises almost 40MB in just over 3,000 files in the AS version. Probably the biggest strength of Uniserver is its compact size, so no problem with the "lean" standard install. It's just that I'm trying to learn how to do it, and hopefully a handy "how-to" in order to get CPAN or PPM working with the standard Uniserver will come out of it, in this topic.
  11. I checked Perldoc for the official way to download and install modules, here: http://perldoc.perl.org/perlfaq8.html#How-...le-from-CPAN%3F And it says, naturally: But if I call Perl with the CPAN arguments as shown in the first of three blocks above from the command line (in Windows) it complains that it doesn't speak CPAN-ese. So... How do I properly call CPAN?
  12. Also, check the Apache logfile for clues on what and where things go awry, and post the results here - i.e., go here http://localhost/a-cgi/errorlog.cgi It's not very efficient to request help with basically "it doesn't work" as the problem descriptor...
  13. This post cannot be displayed because it is in a password protected forum. Enter Password
  14. This post cannot be displayed because it is in a password protected forum. Enter Password
  15. Instead of using MS Wordpad - which is notoriously fallible in recognizing and handling "funny" characters in plain text files - I really, really, really suggest using instead Notepad2 (see http://www.flos-freeware.ch/ for the file & source code) as it's REALLY transparent, and respectful of whatever text file you open with it: recognizes set file and character encoding properly, respects indentation (doesn't substitute tabs with spaces) and creates picture-perfect encoded files. Also, I suggest setting the files in the translation pack to UTF-8 with byte-order marker (sometimes also abbreviated to BOM) as that will resolve all the "garbage character" issues you're having now, with non-English languages (e.g., the accented letters) because you're using the very English language oriented ANSI encoding method... Finally, as to encoding "weird" characters that will be rendered on-screen: which method of HTML entities do you prefer? Numeric or named? I suppose named, e.g.: é for the accented e (é) but I wanted to make sure first... Also, should the ampersand in such encoded entities be escaped, and if so how? Thanks in advance!
×
×
  • Create New...