Jump to content
The Uniform Server Community

MrBertie

Member
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About MrBertie

  • Rank
    Junior Member

Previous Fields

  • Main OS
    Windows Vista
  1. The latest update of Dekiwiki now works properly in Vista...woopee! See Dekiwiki on Vista/XP using Uniform Server for a more polished up-to-date installation guide Important note: you'll need version Hayes 1.8.3b for this to work!
  2. Thought the same too, and I'm running everything as an Administrator (UAC off) but still doesn't work! Funny thing is that this problem only affects the content of pages, not other meta-data, attachments or comments...can't quite see what could cause the problem, like I said XP runs great! Thanks for the thought all the same, I'll find the issue eventually.
  3. Setting up Uniform Server for Dekiwiki: **IMPORTANT: This does not work successfully on Vista (at least for me, it refuses to save edited pages--the Title, Tags, Attachments and Comments all work fine, but not Body Text...still working on it...) I'd like to share my experience setting up Dekiwiki on Uniform Server. I like this WAMP server due to its small size, security and speed. Dekiwiki runs much faster using this than WOS. So let's start here: Download Uniform Server 3.5 (uniserver_3.5); extract into whatever folder you want; I used 'C:\Software\UniformServer', it doesn't have to be in a root drive * use whatever directory you prefer--it creates its own virtual drive to work from, usually 'W:\' _____________________________________________________________ Uniform Server is slimmed down, lean and mean, which means, for Dekiwiki, you'll need to add a few extra modules to Apache2 and PHP5, and enable them: Using full Apache2 version 2.0.59: copy sslaey.dd and libeay32.dll to C:Software\usr\local\apache2\bin copy mod_proxy.so and mod_proxy_http.so into C:Software\usr\local\apache2\modules enable both modules in usr/local/apache2/conf/httpd.conf, by removing the '#' in front Using full PHP 5.2.3.3: copy php_curl.dll to C:\Software\usr\local\php\extensions copy php_mime_magic.dll to C:\Software\usr\local\php\extensions enable extension=php_curl.dll in php.ini enable extension=php_mime_magic.dll in php.ini * i.e. remove the ';' in front ______________________________________________________________ Download the latest ImageMagick files: Install and then copy the resulting folder from C:\Program Files into: 'C:\Software\usr\local\imagemagick' *(new folder) * this could go anywhere but this seemed a logical place... Then uninstall the ImageMagick program again ______________________________________________________________ Download Deki Wiki Hayes and extract it somewhere Copy the folder 'deki-hayes-files\web' to 'C:\Software\www\web' ______________________________________________________________ Edit 'C:Software\usr\local\apache2\httpd.conf', and add the following lines to the virtual hosts section at end: ----------------------------- <VirtualHost *> ServerName dekiwiki DocumentRoot W:/www/web RewriteEngine On RewriteCond %{REQUEST_URI} ^/$ RewriteRule ^/$ /index.php?title= [L,NE] RewriteCond %{REQUEST_URI} !/(@api|editor|skins|config)/ RewriteCond %{REQUEST_URI} !/(redirect|texvc|index|Version).php RewriteCond %{REQUEST_URI} !/error/(40(1|3|4)|500).html RewriteCond %{REQUEST_URI} !/favicon.ico RewriteCond %{REQUEST_URI} !/robots.txt RewriteCond %{REQUEST_URI} !/dummy.php RewriteCond %{REQUEST_URI} !/phpinfo.php RewriteCond %{QUERY_STRING} ^$ [OR] %{REQUEST_URI} ^/Special:Search RewriteRule ^/(.*)$ /index.php?title=$1 [L,QSA,NE] ProxyPass /@api http://localhost:8081 ProxyPassReverse /@api http://localhost:8081 SetEnv force-proxy-request-1.0 1 SetEnv proxy-nokeepalive 1 AllowEncodedSlashes On </VirtualHost> ---------------------------------- * NOTE: some instructions show 'ProxyPass /@api http://localhost:8081 retry=1' however Apache 2.0.59 does not accept this parameter! ______________________________________________________________ Start Uniform Server, using C:\Software\UniformServer\Server_Start.bat * I've created a custom version of this batch file that displays a bit more start up information and also used W:\ if it already exists. Open http://localhost/web/config/index.php in a browser. Fill in the form: Default database Superuser password is 'root' Add the path for ImageMagick convert and ImageMagick identify: W:\usr\local\imagemagick\convert.exe W:\usr\local\imagemagick\identify.exe *Note the use of W:\ for all path roots, this avoid problems later when you want to transfer the server to another drive, USB stick or computer Click 'Install Deki Wiki!' Hopefully the installation went successfully; if not check for error messages and rectify settings where necessary. Upon completion the following line is displayed: "Please run the following commands manually from the command line to complete your installation:" Time to be disobedient, and do this instead: Create the folder 'C:\Software\UniformServer\udrive\dekiwiki' --or-- W:\dekiwiki (*virtual drive should now exist if you started the server!) open 'W:\www\web\config' and: copy mindtouch.deki.startup.xml into W:\dekiwiki copy LocalSettings.php into W:\www\web\ copy AdminSettings.php into W:\www\web\ copy mindtouch.host.bat into W:\www\web\bin\ Using a text editor (e.g. notepad++ NOT Word!): edit mindtouch.deki.startup.xml and change <path.store>c:\dekiwiki\luceneindex</path.store> to <path.store>W:\dekiwiki\luceneindex</path.store> edit mindtouch.host.bat and change C:\dekiwiki\mindtouch.deki.startup.xml to W:\dekiwiki\mindtouch.deki.startup.xml Create the folder 'W:\tmp' * Needed by php for session saving. See php.ini, line 884: session.save_path = "/tmp/" Run W:\www\web\bin\mindtouch.host.bat * NOTE: mindtouch.host.bat needs to keep running, do not close it! There are solutions to hiding it; see below. Open http://dekiwiki/, and enjoy the experience! ________________________________________________ Other issues and solutions: Q. As mindtouch.host.bat must to keep running, how do I get rid of the pesky cmd box running in my taskbar? A. Google for and use 'hide.exe', download it, and put it into the W:\www\web\bin directory. Use it to create a shortcut to the mindtouch.host.bat file Now run run the shortcut instead the batch file...voila, no cmd window! ----------------------- Q. How do I get Deki-Wiki to work nicely with other sites on the same Apache server? A. You need to open your Windows 'hosts' file and add the following line(s): 127.0.0.1 localhost 127.0.0.1 dekiwiki
  4. Shall do. I'm still having problems with Dekiwiki in Vista though; the Uniform Server/Dekiwiki setup works superbly on XP, many times faster than my previous WOS install ;-), but something in Vista is preventing the update of text edits... Working on it!
  5. If you are interested in how I got Dekiwiki working on Uniform Server please see this post
  6. Success! Will post full instructions on Dekiwiki forum... once I can make sense of my own explanations. Thanks for all the advice freely given. I should mention that Dekiwiki runs much fast on Uniserver than WOS or xampplite. So as they say here in Tanzania: 'hongera' (congrats) for an excellent product.
  7. Finally...it seems that the offending line is the retry=1 after the ProxyPass statement. Uniform Server is still using Apache 2.0.59, which does not recognise this argument. Once I remove that then server fires up.
  8. Almost succeeded! Everything appears to work, I can access the my new Dekiwiki site, but I just cannot get mod_proxy to function, so the site does not function corrently. See Trouble with mod_proxy... So, just one last hurdle--it's cost me hours of messing about to get this far, but hopefully worth it! If I succeed I will post the full instructions for those who are interested.
  9. I've almost got Dekiwiki functioning on Uniform Server, apart from one thing... I can't get the proxy module to work correctly. I have created a new virtual host in httpd.conf as follows: ----------------------------------- <VirtualHost *> ServerName dekiwiki DocumentRoot /www/web RewriteEngine On RewriteCond %{REQUEST_URI} ^/$ RewriteRule ^/$ /index.php?title= [L,NE] RewriteCond %{REQUEST_URI} !/(@api|editor|skins|config)/ RewriteCond %{REQUEST_URI} !/(redirect|texvc|index|Version).php RewriteCond %{REQUEST_URI} !/error/(40(1|3|4)|500).html RewriteCond %{REQUEST_URI} !/favicon.ico RewriteCond %{REQUEST_URI} !/robots.txt RewriteCond %{REQUEST_URI} !/dummy.php RewriteCond %{REQUEST_URI} !/phpinfo.php RewriteCond %{QUERY_STRING} ^$ [OR] %{REQUEST_URI} ^/Special:Search RewriteRule ^/(.*)$ /index.php?title=$1 [L,QSA,NE] ProxyPass /@api http://localhost:8081 retry=1 ProxyPassReverse /@api http://localhost:8081 SetEnv force-proxy-request-1.0 1 SetEnv proxy-nokeepalive 1 AllowEncodedSlashes On </VirtualHost> ------------------------------------- By commenting and uncommenting lines I can see that the problem lies with the ProxyPass directives. If I uncomment them the apache server will not start. As mentioned on another thread Installing Dekiwiki... I've now managed to install the correct mod_proxy module and enable them in apache2. But despite searching these forum, Dekiwiki's forums and elsewhere I'm thoroughly stuck! Does anyone know where next to look?
  10. Ahhhhh! Version numbers! Many thanks, that helped me to get mod_proxy working...now let's see if I can get Dekiwiki working this morning.
  11. I added the modules manually, and enabled them in the apache conf file. Now the Uniserver refuses to start until I disable the two proxy modules I need...
  12. I am trying to install the incredible DekiWiki on Uniform Server. I've already succeeded using WOS (after many days and much 'googling') but I much prefer Uniserver... My first problem is that I cannot enable 'mod_proxy' or 'mod_proxy_http'--the server simple stops working if these modules are enabled. They are not included in standard Uniserver release but I have added them manually. Am I missing something? Or are the dependancies for Deki Wiki too many? Any ideas, hints or suggestions would be much appreciated!
×
×
  • Create New...