Jump to content
The Uniform Server Community

hawkesley

Member
  • Content Count

    35
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About hawkesley

  • Rank
    Junior Member

Previous Fields

  • Main OS
    Windows Vista
  1. Hi Could this be an issue with these two variables ${US_ROOTF} and ${HOME} Where are these set so I can check them please. Also ServerName${US_SERVERNAME} I have not set a Server Name as it is my home server.The Ip is dynamic but managed by NO-IP which seems to work fine. If anybody can help em with this please respond as I have to get this site working for a forthcoming birthday. Many thanks.
  2. I have established that I am not getting an index of each web folder but of the Vhost folder for the website. As an experiment I changed the icon in the VHosts file and now that icon shows if I open the link in the index, which I guess means that the Directory being shown is the VHosts. The path is C:\Uniserver\vhosts\hawkesleypublishingsolutions and similarly for the second site. This is the the http- vhost file # Virtual Hosts## Required modules: mod_log_config# If you want to maintain multiple domains/hostnames on your# machine you can setup VirtualHost containers for them. Most configurations# use only name-based virtual hosts so the server doesn't need to worry about# IP addresses. This is indicated by the asterisks in the directives below.## Please see the documentation at # <URL:http://httpd.apache....cs/2.4/vhosts/># for further details before you try to setup virtual hosts.## You may use the command line option '-S' to verify your virtual host# configuration.## VirtualHost example:# Almost any Apache directive may go into a VirtualHost container.# The first VirtualHost section is used for all requests that do not# match a ServerName or ServerAlias in any <VirtualHost> block.## First Virtual Host must be a shallow duplicate of the main host # in httpd.conf <VirtualHost _default_:${AP_PORT}> DocumentRoot ${US_ROOTF_WWW} ServerName ${US_SERVERNAME} ErrorLog "logs/error.log" CustomLog "logs/access.log" common</VirtualHost> <VirtualHost *:${AP_PORT}> ServerAdmin webmaster@hawkesleypublishingsolutions.com DocumentRoot ${US_ROOTF}/vhosts/hawkesleypublishingsolutions ServerName hawkesleypublishingsolutions.com ServerAlias www.hawkesleypublishingsolutions.com *.hawkesleypublishingsolutions.com ErrorLog logs/hawkesleypublishingsolutions.com-error.log CustomLog logs/hawkesleypublishingsolutions.com-access.log common <Directory "${HOME}\vhosts\hawkesleypublishingsolutions"> Options Indexes Includes AllowOverride All Require all granted </Directory> </VirtualHost> <VirtualHost *:${AP_PORT}> ServerAdmin webmaster@somewhere4u.com DocumentRoot ${US_ROOTF}/vhosts/somewhere4u ServerName somewhere4u.com ServerAlias www.somewhere4u.com *.somewhere4u.com ErrorLog logs/somewhere4u.com-error.log CustomLog logs/somewhere4u.com-access.log common <Directory "${HOME}\vhosts\somewhere4u"> Options Indexes Includes AllowOverride All Require all granted </Directory> </VirtualHost> Any thoughts?Best AnswerQuoteMultiQuote
  3. Hi Ric, Yes external access. Commented out Vhosts fine, but now get index of/ for each site. apache config has Directory Index for index.html and index.php which are the two test pages which just say Hell World. Thes show on localhost Ok. I put DirectoryIndex index.html index.php into the .htaccess files but still get index of/ Any suggestions? Thanks
  4. Ok set up Vhosts all looks ok, but I now get a 403 forbidden. This occurred with my previous attempts with Coral 6.8 so I obviously need to do something but what. Any suggestions appreciated.
  5. Hi, Disregard last post. I had apache running. thanks.
  6. Hi Ric, Went to set up Vhost but that option is not executable on the menu. If fact none of the first block is available also. I checked that include extra is unchecked so is there something to turn the Vhosts option on? Thanks.
  7. Thanks Ric, I will do that.
  8. I have set up two directories in www which reflect two domains I have. The directories hold a simple hello world page ( one index HTML mad one index.php) I set these up on uniform server z to test access as I have previously had problems getting virtual host to work on coral 6.8 I can test the IP address fine and ping the sever. I can access the two addresses from the net (not on my local network) How ever when I access the either site I get the Index of/ My DirectoryIndex in the main apache config allows index.php & index.html. I also have that in the .htaccess. Long explanation but is this a question of setting up virtual hosts or is there other things to check first? Any help appreciated.
  9. Hi All I am still having no luck with my virtual host. Please can some one advise. I started again and set up a new uniform server Uniserver2 and configured two vital hosts in the Coral 6.8.9 panel. Both sites are their own directory in www My server is on port 80 The ,htaccess in www is ht access in www #------------------------------------------------------------------------------ # Server root folder www .htaccess # This file provides server security limiting access to the localhost only. # Comment next four lines to deactivate. (Allows external access) #------------------------------------------------------------------------------ Order Deny,Allow Deny from all Allow from 127.0.0.1 Allow from ::1 #------------------------------------------------------------------------------ # To allow execution of cgi scripts in this directory uncomment next two lines. #------------------------------------------------------------------------------ AddHandler cgi-script .pl .cgi Options +ExecCGI +FollowSymLinks #------------------------------------------------------------------------------ # Activate this section to use the Private Server Feature! # Defaults: Username - root; Password - root # Note AuthUserFile: File path is relative to server root # To lock server, uncomment the next 4 lines. (A name and password is required) #------------------------------------------------------------------------------ #AuthName "Uniform Server - Server Access" #AuthType Basic #AuthUserFile ../../../htpasswd/www/.htpasswd #Require valid-user The virtual host file has # First Virtual Host must be a shallow duplicate of the main host # in httpd.conf <VirtualHost _default_:80> DocumentRoot C:/UniServer2/www ServerName localhost ErrorLog "logs/error.log" CustomLog "logs/access.log" common </VirtualHost> <VirtualHost *:80> ServerAdmin webmaster@somewhere4u.com DocumentRoot C:/UniServer2/www/somewhere4u ServerName somewhere4u.com ServerAlias www.somewher4u.com *.somewhere4u.com ErrorLog logs/somewhere4u.com-error.log CustomLog logs/somewhere4u.com-access.log common <Directory "C:\UniServer2\www\somewhere4u"> Options Indexes Includes AllowOverride All Require all granted </Directory> </VirtualHost> <VirtualHost *:80> ServerAdmin webmaster@hawkesleypublishingsolutions.com DocumentRoot C:/UniServer2/www/hawkesleypublishingsolutions ServerName hawkesleypublishingsolutions.com ServerAlias www.hawkesleypublishingsolutions.com *.hawkesleypublishingsolutions.com ErrorLog logs/hawkesleypublishingsolutions.com-error.log CustomLog logs/hawkesleypublishingsolutions.com-access.log common <Directory "C:\UniServer2\www\hawkesleypublishingsolutions"> Options Indexes Includes AllowOverride All Require all granted </Directory> </VirtualHost> Thank you.
  10. I now have somewhere4u in a folder in a the root www and I now get a 403 forbidden on that two. I configured the virtual host using the apache panel the same as before. The https-vhosts,conf has both entries there. I can't see how to fix this.
  11. I have taken another look at my config files. What I had not been looking at was the httpd-vhosts.conf This file has the folowing # # Virtual Hosts # # If you want to maintain multiple domains/hostnames on your # machine you can setup VirtualHost containers for them. Most configurations # use only name-based virtual hosts so the server doesn't need to worry about # IP addresses. This is indicated by the asterisks in the directives below. # # Please see the documentation at # <URL:http://httpd.apache.org/docs/trunk/vhosts/> # for further details before you try to setup virtual hosts. # # You may use the command line option '-S' to verify your virtual host # configuration. # # Use name-based virtual hosting. # #--US_START--------------Do not remove #--US_END----------------Do not remove # # VirtualHost example: # Almost any Apache directive may go into a VirtualHost container. # The first VirtualHost section is used for all requests that do not # match a ServerName or ServerAlias in any <VirtualHost> block. # # First Virtual Host must be a shallow duplicate of the main host # in httpd.conf <VirtualHost _default_:80> DocumentRoot C:/UniServer/www ServerName localhost ErrorLog "logs/error.log" CustomLog "logs/access.log" common </VirtualHost> <VirtualHost *:80> ServerAdmin webmaster@hawkesleypublishingsolutions.com DocumentRoot C:/UniServer/www/hawkesleypublishingsolutions ServerName hawkesleypublishingsolutions.com ServerAlias www.hawkesleypublishingsolutions.com *.hawkesleypublishingsolutions.com ErrorLog logs/hawkesleypublishingsolutions.com-error.log CustomLog logs/hawkesleypublishingsolutions.com-access.log common <Directory "C:\UniServer\www\hawkesleypublishingsolutions"> Options Indexes Includes AllowOverride All Require all granted </Directory> </VirtualHost> Should there be a similar entry for my other site somewhere4u. This site works fine but the file are in C:/UniServer/www not in a folder. Is this what is causing the forbidden? I have implemented some of the suggestions for htaccess and am working my way through them.
  12. Thanks all. I will try these suggestions.
  13. Hi Thanks for that. I have looked for an obvious error but cant find it. I have posted below the config data I am seeing if it helps. Just to note i have an ht access file in the www root and two ht access files in the Vhosts folder. I have two domains. Somewhere4u is in the root www and works. hawkesleypublishingsolutions is in a folder so named in the root www and give the Forbidden message. Apache Virtual Host Port: 80 Document Root :C:/UniServer/www/hawkesleypublishingsolutions Server Name: hawkesleypublishingsolutions.com Server Alias: www.hawkesleypublishingsolutions.com *.hawkesleypublishingsolutions.com Error Log : logs/hawkesleypublishingsolutions.com-error.log Custom LOg:logs/hawkesleypublishingsolutions.com-access.log common Update Host <Directory "C:\UniServer\www\hawkesleypublishingsolutions"> Options Indexes Includes AllowOverride All Require all granted </Directory> List of Host localhost hawkesleypublishingsolutions .ht access in www #------------------------------------------------------------------------------ # Server root folder www .htaccess # This file provides server security limiting access to the localhost only. # Comment next four lines to deactivate. (Allows external access) #------------------------------------------------------------------------------ #Order Deny,Allow #Deny from all #Allow from 127.0.0.1 #Allow from ::1 #------------------------------------------------------------------------------ # To allow execution of cgi scripts in this directory uncomment next two lines. #------------------------------------------------------------------------------ AddHandler cgi-script .pl .cgi Options +ExecCGI +FollowSymLinks #------------------------------------------------------------------------------ # Activate this section to use the Private Server Feature! # Defaults: Username - root; Password - root # Note AuthUserFile: File path is relative to server root # To lock server, uncomment the next 4 lines. (A name and password is required) #------------------------------------------------------------------------------ #AuthName "Uniform Server - Server Access" #AuthType Basic #AuthUserFile ../../../htpasswd/www/.htpasswd #Require valid-user # BEGIN WordPress RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] # add a trailing slash to /wp-admin RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L] RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d RewriteRule ^ - [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L] RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L] RewriteRule . index.php [L] # END WordPress VHosts file contanis 2 folders with .ht access hawkesleypublishingsolutions somewhere4u.com the ht access in both is #------------------------------------------------------------------------------ # Vhosts Server root folder. File .htaccess # This file provides server security limiting access to the localhost only. # Comment next four lines to deactivate. (Allows external access) #------------------------------------------------------------------------------ Order Deny,Allow Deny from all Allow from 127.0.0.1 Allow from ::1 #------------------------------------------------------------------------------ # To allow execution of cgi scripts in this directory uncomment next two lines. #------------------------------------------------------------------------------ AddHandler cgi-script .pl .cgi Options +ExecCGI +FollowSymLinks #------------------------------------------------------------------------------ # Activate this section to use the Private Server Feature! # AuthName: Replace with a suitable name appropriate to your site # AuthType: Do not change # AuthUserFile: ../../../htpasswd Corresponds to folder UniServer\htpasswd # In folder UniServer\htpasswd create a new folder e.g Vhost_1 # In this new folder create a new file named .htpasswd # Edit this file and add a name and passwrd for example # name123:password45 # Path will look like this (replace xxx with your new folder): # ../../../htpasswd/Vhost_1/.htpasswd # Note: AuthUserFile - File path is relative to server root # To lock server, uncomment the next 4 lines. (A name and password is required) #------------------------------------------------------------------------------ #AuthName "Uniform Server - Server Access" #AuthType Basic #AuthUserFile ../../../htpasswd/xxx/.htpasswd #Require valid-user Apache httpd conf file ##====== VIRTUAL HOST =========== #To enable uncomment next line Include conf/extra/httpd-vhosts.conf # Local access to the Apache HTTP Server Manual #Include conf/extra/httpd-manual.conf # Distributed authoring and versioning (WebDAV) #Include conf/extra/httpd-dav.conf # Various default settings Include conf/extra/httpd-default.conf <IfModule ssl_module> # Secure (SSL/TLS) connections Include conf/extra/httpd-ssl.conf </IfModule> # Deflate Module configuration <IfModule deflate_module> Include conf/extra/httpd-deflate.conf </IfModule> # FastCGI Module configuration <IfModule fcgid_module> Include conf/extra/httpd-fcgid.conf </IfModule> # Proxy Html Module configuration <IfModule proxy_html_module> Include conf/extra/httpd-fcgid.conf </IfModule> # Uptime Module configuration <IfModule uptime_module> Include conf/extra/httpd-uptime.conf </IfModule>
  14. I have two domains.The first in the root www as files, the second in a folder in root www I can access the first but not the second which is only available through local host. I configured virtual host using the apache menu in Coral 6.8 and set up a virtual host for the second domain. The vitual host is enabled and the ht access for outside is enabled. In the second domain log I get this 109.152.69.150 - - [28/Apr/2014:17:26:24 +0100] "GET / HTTP/1.1" 403 202 and a message You do not have permission to access on this server Any suggestions as to where to look appreciated.
×
×
  • Create New...