Jump to content
The Uniform Server Community

gratzo

Member
  • Content Count

    30
  • Joined

  • Last visited

Community Reputation

0 Neutral

1 Follower

About gratzo

  • Rank
    Junior Member
  1. I just got the server to run on my Windows 10, 64 bit system, and it took a little bit of fooling around. When I clicked on the UniController, it gave the errors that port 80 was already in use. Every time you start your machine, Windows 10 will likely start IIS, which I believe opens port 80, so, you either have to turn off IIS, or change the port in Uniform Server. (but of course, if you can't get to the controller to change the port, you're stuck). IIS, the World Wide Web Publishing Service is more than likely the culprit. Here's what I did - - go to: Control Panel > Administrative Tools > Services > scroll to the bottom and right click on World Wide Web Publishing Service > select Properties - click Stop - in Startup type: select Manual - click Apply and then OK - make sure that the UniController is also not running (if it is, you can stop it in this same window). - click on the UniController again (right click, open as Administrator), and it should open the controller correctly this time - change the port to anything but 80 and you should be OK. Let me know if this works. (you may want to change your profile to Windows 10, as W7 has different menu's/etc)
  2. Ric - thanks - that tool is a great help! I figured it out. Here's what happened: 1. set up virtual host (test2) for a test folder that WordPress was loaded on - all good 2. went to GoDaddy and created the subdomain and appropriate A(host) record to point the subdomain to my server/IP address - all good 3. went into the local wordpress "options" page to set up the proper "Blog address URL" and "WordPress address URL" - this is what creates the appropriate rewrites in the .htaccess files - [if you don't do that, all of your links will be broken, for example - since WP was originally installed on "localhost/test2", all navigation within WP would try to get you to http://localhost/test2/page1/etc - obviously this would not work outside of the network] 4. all was working fine from the Internet, but when trying to go to some other local folders and localhost - got 403 Forbidden errors. - the cause - WordPress had written into the root .htaccess file a WordPress URL rewrite to deny any traffic not going to WordPress - which essentially locked out all other folders. So, I went into the root .htaccess file, cleared the rewrite - and all is back to normal.
  3. That's the weird part - I disabled virtual hosts in the config file, and there are no .htaccess files in some of the folders, as some are only plain html or php files. (no scripting or complex things going on) Should there be .htaccess files in all folders? (reason I ask is, my copied server which is working does not have .htaccess files in them, and the pages render happily) Next, can you show an example of what you mean by "add it to each virtual host" - I'm not understanding if this is something I do in the config file or in a .htaccess file in each folder. Bottom line, I can't seem to figure out why 2 nearly identical servers are behaving so differently - I must have altered something along the way!
  4. Ric - that worked! Thanks a ton! But now after doing this change, something strange just started - I have 7 test folders on the server, test1, test2, etc. - 4 of them are WordPress installs, and a couple are random web pages, photo albums, etc. What just started happening was I get a 403 Forbidden error on all folders that do NOT have an .htaccess file in them. This is plain weird! I had copied completely the server a while back, saved it on my desktop - so I thought, hmmm, when I started fooling around in my host file (Windows\system32\drivers\etc\host), I must have made a change that the server didn't like - not true. I fired up the copied server, after shutting down the first, and all folders open without the 403 error. Went over to the Apache error log file, and there are all of the FollowSymLinks messages - thing is, I can't even access "localhost" on this server anymore. Only folders that have the .htaccess files in them - I broke something in the process, and have been tearing out my hair trying to go backwards and figure this one out. Have you ever seen this happen?
  5. Trying to figure out if I'm doing anything wrong, or if this is the way that US works locally, and also from outside of the network. I have US v3.3 running on a local machine just fine - with several test folders: www/test1 www/test2 www/test3 etc. The subdomain and domains are set up with GoDaddy, and I'm using the Total DNS tool to point the subdomain that I created to my static IP. I'm using real/live domain names, so the examples below are for demonstration purposes only! I have virtual host activated, and have assigned the variables with the following: NameVirtualHost *:80 <VirtualHost *:80> DocumentRoot /www/ ServerName localhost </VirtualHost> <VirtualHost *:80> DocumentRoot /www/test1 ServerName my-subdomain.my-domain.com </VirtualHost> When I browse to "my-subdomain.my-domain.com" from a machine OFF of my network (I happened to use my work laptop that is VPN'd, so it appears as it's from another part of the world), everything is served great. All goodness comes to an end if I try to browse to the same site from my browser that the UniformServer is residing on. (same machine) What is weird is that if I open FireFox, browse to the same URL ("my-subdomain.my-domain.com"), it gets me to my router, and won't pass through to the server - the router (I assume) creates a redirect and tries to open the admin page for 192.168.1.1 (my router). I get served my router admin page!! Remember, I know that the router is actually passing http traffic as I can get to the US from "outside" my network.... I have Verizon DSL, for some unknown reason I've had the same IP address for 6 months so I'm treating it as static (even though it's dynamic), and they supply the DSL router/modem/switch in an all in one unit. (I had a Cisco/Linksys before that had a little bit better control over port mapping, etc). So, in other words, if I try to browse "locally", from any of the machines to the actual URL ("my-subdomain.my-domain.com"), I get my router admin page served. If I browse from "outside of the network", everything is served fine. I can locally browse the US's machine IP "192.168.1.106/test1" from any machine on the network, and get the site. Is this just a function of how domain names are served locally when using virtual hosts? Am I doing something wrong, or trying to do something that I shouldn't actually be doing? Your virtual host/subdomain/router expertise greatly appreciated!
  6. Hello Olajide, just downloaded the most recent release US 3.3 (while trying to guide a friend on an install over the phone). I mirrored the setup in order to see what was happening on his end, and I got my server to start (in about 15 seconds from the download), but his gave a user/password needed. I looked through the admin panel, and there are 3 lines in the Security Checklist. The first one reads: Change the username:password for the Admin Panel by editing '/htaccess/home... Should that read '/htpasswd?? (instead of htaccess) I thought of creating my own password, so I went over to the config file at \home\admin\www\.htaccess and un-commented the 4 lines, which are: AuthName "Uniform Server - Admin Panel 1.0 Alpha" AuthType BAsic AuthUserFile /htpasswd/home/admin/www/.htpasswd Require valid-user Went to shutdown the server and got the username/password prompt. So, since I hadn't changed the default user/password, I figured that admin/userver would work - but no dice. Did I uncomment the wrong lines, or do I need to change something else in the .htaccess file in order to have a new username/password?
  7. Just to clarify, to add site2, site3, site4, etc. I would copy the above format and enter the username/password variables and have individual access to the different users? If that's the case, I'm thinking that the "Mount /files D:\files" is what broke it! Glad you're back up - was getting nervous that the UniformServer vanished!
  8. I currently have 5 "sites" hosted on the Uniform Server and am using the Apache virtual host mod. They are set up as W:/www/site1, W:/www/site 2, etc. At the moment, I'm able to (via slim ftp) FTP into the Uniform Server, and see all of the folders, per the default config in SlimFTP. The default code is: <User "myusername"> password "mypassword" Mount / W:/ Allow / All Mount /files D:\files </User> What I tried to add (in a whole new section of the config file), was: <User "mysite1username"> password "mysite1password" Mount / W:/www/site1 Allow / All Mount /files D:\files </User> That's what "broke" the server, or then refused the connection. What I'm trying to do is allow access via FTP to only the "site" folders themselves - and the above code didn't seem to do it. Maybe this is not a possibility, but looking for direction. So... 1. is it possible to add another user account and limit it to just the new "site" folders? 2. since I'm running the vhost module, does this have any effect on what the URL would be? I tried copying the exact format that's in SlimFTP for another user, and got a "connection actively refused" while trying to connect. I commented out the new user section and got right back in, so I know it was something in the way I wrote the additional user info. Your help greatly appreciated!
  9. OK, after stumbling upon a 2002 post about Apache Server, here's what I found, and it's pretty similar to your instructions. For each virtual host, I had to create another set of instruction - (for kicks, I tried putting it all in one "Virtualhost" command, but it didn't work): This is the code that I put into the config file for the virtual host <VirtualHost *> DocumentRoot /www/site1 ServerName mydomain.com </VirtualHost> <VirtualHost *> DocumentRoot /www/site1 ServerAlias www.mydomain.com Redirect permanent / http://mydomain.com </VirtualHost> So you don't have to look back and forth at the former code, 1. I removed the "www" in the "ServerName" line 2. Added the new "VirtualHost" section 3. created "ServerAlias" with www.mydomain.com 4. created the "Redirect permanent" line that points it to the new URL w/o the "www" Nothing needed to be done to the .htaccess file, in fact, I took it out to make sure there was not effect. Bottom line, this can be done via the Apache virtual domain and a simple bit of code in the config file. I hope this isn't just a fluke that it's working for me!
  10. trying to figure out why I'm reaching the "root" folder of my Uniform Server when I don't type in the "www" in front of the URL. Works fine when I type "www.mydomain.com", but when I type in "mydomain.com", it resolves to the root folder, and not the virtual host set up. Here is the detail behind this: Uniform Server v3.2 vhost module installed and running dynamic IP via dns.afraid.org For the dynamic DNS entries, I have entered both of these to forward to the Uniform Server: "mydomain.com" "www.mydomain.com" I know that part is working, because when you enter the URL's, both addresses hit the server, only one hits the virtual host, the other hits the root. The virtual host entries in the config file are set to the following: NameVirtualHost * <VirtualHost *> Document Root /www/ ServerName localhost </VirtualHost> <VirtualHost *> Document Root /www/site1 ServerName www.mydomain.com </VirtualHost> I'm trying to do a rewrite with .htaccess to allow anyone to see the site on the virtual host with and without the "www". This is the code that I wrote into the .htaccess file, which obviously is NOT working correctly...and where I think I need the help Options +FollowSymlinks RewriteEngine On RewriteCond %{HTTP_HOST} ^www\.mydomain\.com$ [NC] RewriteRule ^(.*)$ http://mydomain.com/$1 [R=301,L] I know in theory this should work, I just have something twisted in either the .htaccess file, or in the virtual host (httpd) Apache config file. Again, bottom line is (and I hope I'm not overcomplicating something that may be very simple) I'm just trying to resolve to the same place with and without "www" on my uniform server, with the virtual host running.
  11. Thanks - I'll give it a go and report back in this thread if it's a success. - g
  12. Ok, I think I'm getting it now. I was hoping to be able to point to my current SMTP server, which is my ISP's - but it appears I need my own SMTP server installed with UniformServer. You gave a quick tutorial back in April - I'll look at that (I think you mentioned installing the hmail server) ...bottom line, I need to install a mail server...Is this correct? On the other hand...since php has a sendmail function in it (somewhere...I think), couldn't I just re-insert that into the php files (again somewhere) and activate it? (You suggested doing this with the EXIF file, hoping to do the same with sendmail) I could be way off base, but it seems like the Uniform Server has many of the features of all of the combined programs stripped out to keep it light and nimble (no dust) - this is one option that would help complete my overall server. thanks!
  13. It seems that there should be some place that the username/password should go to enable an SMTP message. That's what I'm not seeing. I entered the SMTP server address of my ISP, "smtp.sbcglobal.net", since that's really the only variable that is in the php config file. All of my current mail goes out through outlook/SMTP via my ISP, off of a shared server - and it seems like some sort of authentication values need to be put in...somewhere??? Has anyone gotten the sendmail function to work with SMTP...and if so, how?
  14. Ok, now that I've found the SMTP = localhost and smtp_port = 25, can you show me a quick example of what values I should enter? On the php.net SMTP/sendmail page it shows the default values but nothing else. (such as how to activate it or any sample code). Wondering if I need to install another file to allow SMTP. I have my own SMTP values from my ISP, just not sure where in the config file I should enter them.
  15. I have a small photoblog that will send a short text or html e-mail when a comment is posted. It's similar to the e-mails that are sent when you enable the email notification in a post on this forum. Trying to enable the sendmail function - I've searched the forum for a specific answer, but was unable to get the specifics to enable the sendmail function. I did locate info on setting up SMTP mail, but my need is more simplistic. I located the "sendmail_from = me@localhost.com" and the ";sendmail_path =" in the php configuration file, but not sure what to set the parameter to. Also searched on the www.php.net site, and noticed that the file path is typically usr\lib\sendmail, or something similar - not finding a sendmail file within UniformServer's php file... Would like to enable this function for 2 reasons - 1, to know when a comment is made (duh), and second, to curb any possible comment spam, should that ever be a problem. Currently using US v3.2a on Win2000 Professional, virtual domain hosting enabled/installed. Thanks in advance for all of your support and timely answers! g
×
×
  • Create New...