Jump to content


Photo

Uniform Server 8.8.2 InnoDB = Disabled

8.8.2 MYSQL DATABASE INNODB BUG

  • Please log in to reply
1 reply to this topic

#1 Miller

Miller

    Newbie

  • Member
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Nairobi
  • Interests:IT, Tourism
  • Main OS: Windows 7

Posted 15 April 2013 - 10:16 AM

Gentlemen, ladies;

How do I get Innodb to work? #skip-innodb has no effect. Is it possible that this version of mysql was compiled without innodb support?

To replicate the issue:
1. start myqsl console
2. type myqsl -uroot -proot
3. then on the mysql prompt, type show variable like 'have_innodb';



[EDIT]

Sorry guys, its not a problem with Uniform Server 8.8.2. It turns out that the following two settings in the MySQL my.ini file automatically disables innoDB:

1. innodb_log_file_size with a value greater than 5M, and
2. innodb_flush_method = O_DIRECT

#2 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,336 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 7

Posted 23 April 2013 - 01:42 AM

No problem.





Also tagged with one or more of these keywords: 8.8.2, MYSQL, DATABASE, INNODB, BUG

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users