Jump to content


DanD

Member Since 19 May 2008
Offline Last Active Dec 05 2008 10:06 AM
-----

Topics I've Started

CGI Scripts will not run

05 December 2008 - 09:08 AM

I have tried everything I can think of, but I can not get my pl/cgi scripts to run. This is a windows box with all uniserver settings as it comes default.

I can not seem to run scrips from the main directory or the cgi-bin, and yes THE FILE IS IN THE DIR.

Please help me get this working.

This the result on the webpage:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache/2.0.59 (Win32) DAV/2 PHP/5.2.3 Server at localhost Port 80



Here is the error log:

[Fri Dec 05 07:58:51 2008] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: W:/cgi-bin/hello.pl
- [Fri Dec 05 07:58:51 2008] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: hello.pl
- [Fri Dec 05 07:54:53 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't spawn child process: W:/www/hello.cgi
- [Fri Dec 05 07:54:53 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't create child process: 720002: hello.cgi
- [Fri Dec 05 07:52:11 2008] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: W:/cgi-bin/hello.pl
- [Fri Dec 05 07:52:11 2008] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: hello.pl
- [Fri Dec 05 07:32:26 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't spawn child process: W:/www/hello.pl
- [Fri Dec 05 07:32:26 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't create child process: 720002: hello.pl
- [Fri Dec 05 07:29:11 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't spawn child process: W:/www/hello.cgi
- [Fri Dec 05 07:29:11 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't create child process: 720002: hello.cgi
- [Fri Dec 05 07:28:23 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't spawn child process: W:/www/hello.cgi
- [Fri Dec 05 07:28:23 2008] [error] [client 127.0.0.1] (OS 2)The system cannot find the file specified. : couldn't create child process: 720002: hello.cgi
- [Fri Dec 05 07:23:58 2008] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: W:/www/hello.cgi
- [Fri Dec 05 07:23:58 2008] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: hello.cgi


This is the cgi
#! /usr/local/bin/perl

# hello.pl -- my first perl script!

print "Content-type: text/html\n\n";

print <<"EOF";
<HTML>

<HEAD>
<TITLE>Hello, world!</TITLE>
</HEAD>

<BODY>
<H1>Hello, world!</H1>
</BODY>

</HTML>
EOF