Jump to content


Photo

Omeka Install Problems


  • Please log in to reply
1 reply to this topic

#1 johndeschamps

johndeschamps

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows Vista

Posted 30 April 2011 - 09:38 AM

Hi All,

I am trying to do a fresh install of Omeka 1.3.2 on Orion 7.0.1 and it keeps failing on the following:

Fatal error: Uncaught exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Duplicate entry '1' for key 'PRIMARY'' in C:\UniServer\www\omeka\application\libraries\Zend\Db\Statement\Mysqli.php:214 Stack trace: #0 C:\UniServer\www\omeka\application\libraries\Zend\Db\Statement.php(300): Zend_Db_Statement_Mysqli->_execute(Array) #1 C:\UniServer\www\omeka\application\libraries\Zend\Db\Adapter\Abstract.php(468): Zend_Db_Statement->execute(Array) #2 [internal function]: Zend_Db_Adapter_Abstract->query('?INSERT INTO `o...', Array) #3 C:\UniServer\www\omeka\application\libraries\Omeka\Db.php(82): call_user_func_array(Array, Array) #4 C:\UniServer\www\omeka\application\libraries\Omeka\Db.php(284): Omeka_Db->__call('query', Array) #5 C:\UniServer\www\omeka\application\libraries\Omeka\Db.php(284): Omeka_Db->query('?INSERT INTO `o...', Array) #6 C:\UniServer\www\omeka\application\libraries\Omeka\Db.php(300): Omeka_Db->exec('?INSERT INTO `o...') #7 C:\UniServer\www\omeka\application\libraries\Ome in C:\UniServer\www\omeka\application\libraries\Zend\Db\Statement\Mysqli.php on line 214

This is the response I have gotten so far from the omeka devs:

It looks like you need to drop or truncate or otherwise clear out your database.

That error shows that the installer is trying to add a duplicate row to a table, which means you've got old data already sitting around in the database you're trying to install to.

You can drop the tables from your database, or make a new database and point Omeka at that one, or just change the "prefix" setting in db.ini. Any of those option will make sure that there's no old tables floating around.


However, I these are fresh installs of both Uniform Server and Omeka.

Anyone have any clues?

#2 Coral

Coral

    Junior Member

  • Member
  • Pip
  • 40 posts
  • Main OS: Windows XP

Posted 04 May 2011 - 09:22 AM

Duplicate error! Your first install of Omeka installed tables; you are trying to install again hence duplicate errors.

I think real problem is you cannot install Omeka on a WAMP it must be a LAMP stack
Ref: This Google result
http://groups.google...9f001b93ae37028




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users