Jump to content


Photo

backup disappear


  • Please log in to reply
7 replies to this topic

#1 ahmedhoukry

ahmedhoukry

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 27 June 2006 - 07:54 PM

Dear All
whenever i do a backup to my database using the backup utiliy in phpadmin

after a couple of days , my backup doesnt show in the "import" tab

and i also had a backup file in another place , when i tried to put in the directory to import , it did not show up to import tab

#2 MrX

MrX

    The Mad Theorist

  • Support Team
  • PipPip
  • 167 posts
  • Location:IRC :P
  • Wiki ID: MrX
  • IRC Nickname: MrX, MrX- and MrX_

Posted 28 June 2006 - 01:53 AM

What do you mean by it doesn't show up in the "import" tab? Do you mean not listed when you press the "browse" button?

How're you putting in the directory to import? Did you type the path of that directory into the textbox or did you use the "browse" button?

#3 ahmedhoukry

ahmedhoukry

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 28 June 2006 - 02:37 PM

I mean when i press on the import tab, i get "there are no backup files to import" , although i did backup a couple of days before,

the second thing
I am trying to backup the file but i get this message

Fatal error: Maximum execution time of 60 seconds exceeded in W:\home\admin\www\phpMyBackupPro\functions.inc.php on line 514

#4 MrX

MrX

    The Mad Theorist

  • Support Team
  • PipPip
  • 167 posts
  • Location:IRC :P
  • Wiki ID: MrX
  • IRC Nickname: MrX, MrX- and MrX_

Posted 29 June 2006 - 12:43 AM

What are you using? phpMyAdmin or phpMyBackupPro?

The maximum execution time limit is a safety feature to prevent poorly written scripts from tying up the server, but sometimes it can also prevent good scripts from performing tasks that take a very long time to complete.

Anyway, you can change the maximum execution time by opening W:\home\admin\www\phpMyBackupPro\.htaccess (it isn't there by default so you'll have to create it) in notepad and adding "php_value max_execution_time <integer>" to it, <integer> is the number of seconds a script is allowed to run before it is terminated. Something like 300 should work, but if you're still getting that error, keep increasing it by 60 until the error's gone :)

Just remember that by increasing the maximum execution time, you'll be allowing scripts to use more resources on your server :)

Edited by MrX, 29 June 2006 - 02:00 AM.


#5 ahmedhoukry

ahmedhoukry

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 29 June 2006 - 04:29 AM

I am using phpMybackupPRO
icreated a file .htaccess
and did put this line "# php_value max_execution_time 200"

but it did not work why ?

also , why do older files get deleted

Dear Sir
I found out why it deletes the files in the extended config tab

but now i cannot backup due to time limit, maybe because the database is large

#6 ahmedhoukry

ahmedhoukry

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 29 June 2006 - 04:43 AM

i solved it
i fount the timelimit in extended config
sorry for wasting your time

#7 MrX

MrX

    The Mad Theorist

  • Support Team
  • PipPip
  • 167 posts
  • Location:IRC :P
  • Wiki ID: MrX
  • IRC Nickname: MrX, MrX- and MrX_

Posted 29 June 2006 - 05:11 AM

Who gave you the idea to comment that line by adding a # in front of it? By commenting something, you're telling Apache to ignore it.

Also, what do you mean by extended config? Do you mean W:\usr\local\php\php.ini? If you do, I recommend that you don't modify that as you'll make it apply to the entire server. phpMyBackupPro might not be a poorly written script, but there certainly are some of those out there and who knows, you might just use one. Putting the config in the .htaccess file will make that setting only apply to phpMyBackupPro, which we know needs such a long time to complete as you have a big database and not because it is poorly written.

Unless you're only going to use phpMyBackupPro with Uniform Server, I hope that you'll consider what I have said, change the php.ini setting back to what it was and use .htaccess instead.

#8 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 09 July 2006 - 05:05 PM

:( So what was the problem....?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users