Jump to content


Photo

Upgrading to UniServer Zero 12.2.0 -- Problems


  • Please log in to reply
2 replies to this topic

#1 Len Jacobson

Len Jacobson

    Junior Member

  • Member
  • Pip
  • 15 posts
  • Gender:Male
  • Main OS: Other

Posted 11 March 2016 - 02:02 AM

I am trying to upgrade my previous version of Uniform Server to UniServer Zero 12.2.0 on my Windows 10 laptop.  At present, I have the following two problems:

 

  1. According to 'phpinfo()', the PHP configuration file (php.ini) is located in the C:\Windows directory.  But it's not there.  Am I expected to create that file and place it in that directory?  If so, do I use use the 'php_test.ini' file (or the 'php_development.ini' file or the 'php_production.ini' file) and modify it as I want and save it then as 'php.ini' in the C:\Windows directory?  Or do I simply modify one of those three files as needed, leave it in its current directory, and then use the UniController to select the chosen .ini file?
  2. UniServer Zero 12.2.0 comes with PHP 7.0 as the default version.  I see in the documentation that I can install earlier versions of PHP (e.g., 5.6) and that I should download the desired version(s).  And I see the file name of the various earlier versions of PHP (e.g., ZeroXII_php_5_6_x.exe).  But nowhere do I see a link to download the needed file(s).

I would appreciate help with these two issues.

 

Thank you very much.

 

Len Jacobson



#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 11 March 2016 - 05:11 AM

1) "Or do I simply modify one of those three files as needed, leave it in its current directory, and then use the UniController to select the chosen .ini file? " This is correct.

 

Although “Configuration File (php.ini) Path" shows C:\WINDOWS this path is ignored even if it contains a php.ini file. The configuration file loaded is that selected by UniController, on start-up PHP is forced to load only this file.

The php info “Loaded Configuration File” is the one that php is currently using.

 

2) “And I see the file name of the various earlier versions of PHP (e.g., ZeroXII_php_5_6_x.exe).  But nowhere do I see a link to download the needed file(s). ”

 

Not sure I fully understand the problem!

The needed files are contained in self-extracting archives for example ZeroXII_php_5_6_19_g.exe

Download this file from the modules folder https://sourceforge....ZeroXIImodules/

Copy the downloaded file to folder UniServerZ.

Stop servers and close UniController if running, double click downloaded file in folder UniServerZ.

This extracts all required files for php 5.6.19.

Start UniController and select php version php56 this switches to php 5.6.19

You are now ready to run the servers.

 

All the best

Ric



#3 Len Jacobson

Len Jacobson

    Junior Member

  • Member
  • Pip
  • 15 posts
  • Gender:Male
  • Main OS: Other

Posted 11 March 2016 - 09:24 AM

Ric,

 

You have answered my two questions perfectly and I thank you!!

 

Regarding the download of ZeroXII_php_5_6_19_g.exe, I didn't know where to find it.  You gave me the link to its location and that is what I needed.

 

Again, thank you very much.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users