Jump to content


Photo

Virtual hosts?


  • Please log in to reply
24 replies to this topic

#21 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 07 May 2005 - 07:03 PM

I am confused by your post... what do u mean, ofcourse it is suppose to link you to the W:/www/aa1 folder because that is what you set :P

What do you mean:

i got index.php in /www/ wich redicts to /aa/


Also i hope you have the .so file in the modules folder of Apache?

#22 bebbet

bebbet

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 08 May 2005 - 04:17 AM

i got the server

W:/www/ the root, if someone gets in the root (so not subdirs) i got PHP script:

header(location: /aa/)

so that it redicts to

W:/www/aa/

my main site (i didn't want it in the root...)
but if i try to pass trough the virtual host i only get to that location

#23 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 08 May 2005 - 07:23 AM

If you have mod_vhost_alias activated with the module in the Apache Module folder, it is suppose to work.

Here is what i want you tod o to ensure i am able to help you right, i want you to paste the vhost setting here from the httpd.conf file.

From what i understand you are trying to make a vhost but it redirects to the W:/www/ folder so you put PHP file there to redirect to W:/www/aa/, am i right? :P

Thanks

#24 bebbet

bebbet

    Newbie

  • Member
  • Pip
  • 6 posts

Posted 08 May 2005 - 04:15 PM

my whole httpd.conf

Attached File  httpd.txt   30.91KB   283 downloads

#25 olajideolaolorun

olajideolaolorun

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 2,347 posts
  • Gender:Male
  • Location:Atlanta, GA
  • SourceForge IDempirex
  • Wiki ID: olajideolaolorun
  • IRC Nickname: Olajide
  • Main OS: Windows 10

Posted 08 May 2005 - 04:37 PM

Try this and put the rest of the codes that are not here but you want in a .htaccess file under the folder after this is working...

<VirtualHost *>
    ServerAdmin webmaster@bebbet.kicks-ass.net
    DocumentRoot /www/bebbet
    ServerName bebbet.kicks-ass.net
    ErrorLog logs/bebbet.kicks-ass.net-error_log
    CustomLog logs/bebbet.kicks-ass.net-access_log common
</VirtualHost>

#------

<VirtualHost *>
    ServerAdmin webmaster@free-hosting.kicks-ass.net
    DocumentRoot /www/free-hosting
    ServerName free-hosting.kicks-ass.net
    ErrorLog logs/free-hosting.kicks-ass.net-error_log
    CustomLog logs/free-hosting.kicks-ass.net-access_log common
</VirtualHost>

Try that, make sure that the domain names are set to go to your ip on the pc that the server is on or you can use the vhost script here to make the virtual host... I do not know where you got your own version of the code from but i am absolutly sure that it is buggy and will never work because you do not have most of the needed things set.

Put that code in the httpd.conf file, just that code alone, nothing added and test it... make sure the domain is also pointing to the server or edit your windows http file to redirect all calls to localhost...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users