Jump to content


Photo

Wordpress needs more memory. Update php.ini for this?


  • Please log in to reply
3 replies to this topic

#1 Cheesysocks

Cheesysocks

    Newbie

  • Member
  • Pip
  • 8 posts
  • Main OS: Windows 7

Posted 07 May 2014 - 10:23 AM

Hi all.

 

 

I'm using Wordpress 3.9 on the latest UniserverZ of 11.1.6. Trying to install plugins sometimes locks up at "Unpacking". Google tells me this may be due to PHP.INI needing to be increased.

 

 

 

"You need to change the memory_limit in the php.ini for your server. Changing it at runtime has typically no effect (on shared hosting anyway), much less the WP_MEMORY_LIMIT constant."

 

 

 

On looking into my Uniform Server files I find three versions of PHP.INI. Which one should I use and do you think this is the correct answer?

 

Mike.



#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 07 May 2014 - 01:33 PM

For Uniform Server preferably change all three configuration files.

From UniController select:
PHP > Edit Basic and Modules > Edit Basic Configuration
In the pop-up menu:
For all three files set "Maximum Memory Amount(MB)" to 128M

Note: In wordpress edit wp-config.php file:
Add the following line: define('WP_MEMORY_LIMIT', '128M');

 

All the best

Ric



#3 Cheesysocks

Cheesysocks

    Newbie

  • Member
  • Pip
  • 8 posts
  • Main OS: Windows 7

Posted 07 May 2014 - 01:53 PM

Good evening Ric.

 

For Uniform Server preferably change all three configuration files.

From UniController select:
PHP > Edit Basic and Modules > Edit Basic Configuration
In the pop-up menu:
For all three files set "Maximum Memory Amount(MB)" to 128M

Note: In wordpress edit wp-config.php file:
Add the following line: define('WP_MEMORY_LIMIT', '128M');

 

All the best

Ric

 

Thanks for your feedback on this. I had no idea that there was such a simple way to get to the important stuff in the ini files! What a great community.

 

However... I have made the changes as recommended; while Uniserver was not running, saved the ini's and modified and saved the config file. Restarted it and tried installing a plugin. This is how it freezes. I'm on a windows 7 machine with an i5 and 8 gig ram installed so there's no shortage of oomph.

 

I'll recheck the settings, I hope I find something wrong.

 

 

Installing Plugin: MailPoet Newsletters 2.6.6

Downloading install package from https://downloads.wo...tters.2.6.6.zip

Unpacking the package…

 

 



#4 Cheesysocks

Cheesysocks

    Newbie

  • Member
  • Pip
  • 8 posts
  • Main OS: Windows 7

Posted 07 May 2014 - 02:04 PM

Checked PHP > Edit Basic and Modules > Edit Basic Configuration.

 

All 3 files showing 128m

 

Checked wp-config.php

 

define('WP_MEMORY_LIMIT', '128M');

This is immediately after the other defines, the 8 x salt's.

 

So something else must be at fault. Never mind, This is the PHP forum and my question here is answered. Thanks again.

 

Mike.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users