Jump to content


Photo

Uniserver cannot find php_gpsql.dll nor php_pdo_pgsql.dll

Postgresql

  • Please log in to reply
1 reply to this topic

#1 jkurrle

jkurrle

    Newbie

  • Member
  • Pip
  • 2 posts
  • Main OS: Windows 7

Posted 01 May 2014 - 03:43 PM

I am on Uniform Server 11.1.15.  I have PHP versions 5.3 and 5.4 loaded and switch between them, but normally use PHP version 5.3.  I try to enable the php_pgsql and php_pdo_pgsql extensions, but when I start Apache, I get the following errors:

 

PHP Startup: Unable to load dynamic library 'C:/Users/John/Desktop/UniServerZ/core/php53/extensions\php_pdo_pgsql.dll' - The specified module could not be found.

PHP Startup: Unable to load dynamic library 'C:/Users/John/Desktop/UniServerZ/core/php53/extensions\php_pgsql.dll' - The specified module could not be found.

 

I checked the physical directory where the error message is referring to and the modules are, in fact, there.  Can anyone give me an idea of how to get Uniserver to activate them?

 



#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 02 May 2014 - 04:35 AM

In all older versions of PHP libpq.dll is missing.

Download the latest module version as appropriate:

ZeroXI_php_5_3_28b.exe

ZeroXI_php_5_4_28a.exe

ZeroXI_php_5_5_12a.exe

ZeroXI_php_5_6_0_beta2.exe

 

To enable php_pdo_pgsql.dll and php_pgsql.dl use one of the following methods:

 

From UniController:

Select the PHP version

Select the configuration file

Select “Edit Basic and Modules” from this select “PHP modules Enable/Disable”

In the pop-up menu click pgsql.dll and php_pgsql

 

Alternatively manually edit configuration files:

For each PHP version edit the following configuration files:

\core\php5*\php_development.ini

\core\php5*\php_production.ini

\core\php5*\php_test.ini

 

Locate these lines:

;extension=php_pdo_pgsql.dll
;extension=php_pdo_sqlite.dll
;extension=php_pgsql.dll

Change to:

extension=php_pdo_pgsql.dll
;extension=php_pdo_sqlite.dll
extension=php_pgsql.dll

Restart servers.

 

All the best

Ric






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users